Submit a ticketCall us

Don’t fall victim to a ransomware attack
Backups are helpful, but sometimes that’s not enough to protect your business against ransomware. At our live webcast we will discuss how to protect against ransomware attacks with SolarWinds® Patch Manager and how to leverage log data to detect ransomware. Register now for our live webcast.

Home > Success Center > Patch Manager > Install failed. Fatal error during installation HResult: 0x80070643

Install failed. Fatal error during installation HResult: 0x80070643

Updated December 14, 2016

Overview

This article provides brief information and steps to resolve the following MSI installer error when installing Java8u112 update:

Exception Details
Install failed. Fatal error during installation HResult: 0x80070643

Environment

All Patch Manager versions

Cause 

The issue is caused by corrupted Java installer.

Resolution

  1. Delete old Java updates from the Patch Manager console.
  2. Expand Administration and Reporting, and then click Software Publishing > Sun packages node.
  3. Re-download Java update:
    a. Go to the Patch Manager console.
    b. Expand Administration and Reporting, and then click Software Publishing. 
    c. Click Patch Manager Configuration Wizard to connect to SolarWinds catalog to retrieve the list of all available catalogs. (Click Next until the end) or Click Synchronization Settings > Synchronize to get the Java update again.
  4. Publish and approve the package.
  5. Deploy the package using Update Management on target machine.
  6. Verify if it was successful through Task history.

 

 

 

Last modified
22:52, 13 Dec 2016

Tags

Classifications

Public