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Home > Success Center > Patch Manager > Failed to send task to automation server

Failed to send task to automation server

Created by Leif Amland, last modified by Karen Valdellon on Jul 03, 2017

Views: 40 Votes: 0 Revisions: 7

Updated: 3rd July, 2017

Overview

This article addresses an issue where the following error is returned when executing an update task:

Failed to send task to automation server

Environment

All Patch Manager versions

Cause 

This issue can occur because of the following:

  • The automation server is misconfigured.
  • Communication between automation servers has been blocked. 
  • The automation server was an unnecessary additional install onto the primary automation server.

Resolution

  1. Verify that the automation server and primary automation server can communicate over port 4092. 
  2. Verify the details of the automation server in Patch Manager:
    1. Patch Manager > Patch Manager System Configuration > Patch Manager Servers > Application Servers.
    2. Click the automation server in the middle pane and review the details in the lower pane.
  3. To adjust the configuration, highlight the automation server and click "Patch Manager Server Wizard". 
  4. Select "Edit an existing Patch Manager Server's configuration settings."
  5. Follow the wizard, correcting the settings as needed. 

 

Clear the automation server configuration and re-install Patch Manager

  1. Clear the automation server from Patch Manager, this removes both the automation server and routing rules that are in place:
    1. Go to Patch Manager System Configuration > Patch Manager Servers.
    2. Highlight the automation server.
    3. In the Actions pane, select Delete.
  2. Remove the automation server:
    1. Uninstall Patch Manager on the automation server.

    2. Delete the EminentWare registry key: Hkey_Local_Machine/Software/EminentWare

    3. Delete any remaining Patch Manager files in Program Files.

    4. Run SQL Management Studio and clear the record for PAS from dbo.gc_device and dbo.device. Perform this for both the primary server and automation server databases.

  3. Reinstall Patch Manager Automation Server.

 

Disclaimer: Please note, any content posted herein is provided as a suggestion or recommendation to you for your internal use. This is not part of the SolarWinds software or documentation that you purchased from SolarWinds, and the information set forth herein may come from third parties. Your organization should internally review and assess to what extent, if any, such custom scripts or recommendations will be incorporated into your environment.  You elect to use third-party content at your own risk, and you will be solely responsible for the incorporation of the same, if any.

 

Last modified
16:47, 3 Jul 2017

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