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Home > Success Center > Orion Platform > The client or server is only configured for E-mail addresses with ASCII local-parts

The client or server is only configured for E-mail addresses with ASCII local-parts

Updated January 3, 2018

Overview

In the ActionsExecutionAlert.log, the error message gives the following message with the offending email address:

The client or server is only configured for E-mail addresses with ASCII local-parts

 

Environment

  • All versions of Orion
  • Email server configured to only allow ASCII values in the email address

 

Cause 

If the email address in the alert is using a custom property, the value of the custom property does not conform to email address requirements in the SMTP server. If the email address in the alert is typed directly into the alert, the value entered does not conform to email address requirements in the SMTP server.

 

Copy (CTRL+C) and pasting (CTRL+V) from one window to another can include non-ASCII characters. Therefore, the non-conforming characters may not be detected in the custom properties values or in the To line of the alert, or be visible to the user.

 

To verify if the email address has non-ASCII characters, copy (CTRL+C) the email address out of the ActionsExecutionAlert.log and paste it into Notepad. Then save the file as ANSI encoding. If you have to use any of the UTF or Unicode encoding to save the file, there are non-ASCII characters in the email address.

 

Resolution

  1. The ActionsExecutionAlert.log message contains the date and time of the alert and the subject line of the email.  Search the AlertHistoryView table in the Orion Database for the alert. 
    • The time in the ActionsExecutionAlert.log is in local time.  One can match that time to the TimeStamp column AlertHistoryView which is in UTC. 
    • One can also search for a portion of the subject line.  A part of the string matches to the Message column in the AlertHistoryView.
    • The column, EventTypeWord in the AlertHistoryView,  will contain "ActionFailed" for the failure.
  2. Using the AlertHistoryView.AlertID, you can cross-reference to the AlertConfigurations.AlertID column.  The name of the Alert is in the Name column in the AlertConfigurations table.
  3. Either correct the To address of the alert (check Trigger Action and Reset Action), or correct the value in the custom property.

 

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  • Alternatively, you can paste the email to Notepad++
  • Change the Encoding to ANSI
  • Make sure there's no special character
  • Paste the email again to your Alert Action or Custom Property

 

 

 

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