Submit a ticketCall us
Home > Success Center > Orion Platform > Orion Documentation > Troubleshoot orphaned limitations in Orion Platform products

Troubleshoot orphaned limitations in Orion Platform products

Created by Magdalena.Markova, last modified by Oksana.Pasirska on Dec 14, 2017

Views: 263 Votes: 0 Revisions: 11

Updated: December 5, 2017

Overview

When active diagnostics detects orphaned limitations in your Orion Platform products, you are asked to delete these records from the database because they may cause performance issues and errors in logs.

Environment

  • Products with Orion Platform 2017.1 and later, such as NPM 12.1 and later

Cause

Orphaned limitations reference nodes that are no longer present in the database.

Resolution

Before you delete orphaned limitations, make sure your Orion Platform products are not using them.

Delete orphaned limitations from the database:

  1. Stop Orion services on the server hosting your Orion Platform product, for example using the Orion Service Manager.
  2. Create a backup of your database.
  3. Start the Database Manager, and run the following query:
    DELETE FROM [Limitations] WHERE [LimitationID] NOT IN 
    (select [LimitationID1] as LimitationID from [Accounts] where [LimitationID1] is not null union 
    select [LimitationID2] as LimitationID from [Accounts] where [LimitationID2] is not null union 
    select [LimitationID3] as LimitationID from [Accounts] where [LimitationID3] is not null union 
    select [LimitationID] as LimitationID from [Views] where [LimitationID] is not null)
    
  4. Run the database maintenance.
  5. In the Orion Service Manager, start all Orion services.

You have deleted all orphaned limitations from the database.

Last modified

Tags

Classifications

Public