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Home > Success Center > Orion Platform > Orion - Knowledgebase Articles > Unable to Mute Alerts: "Failed to schedule maintenance. Check your SWIS/Database connection and try again"

Unable to Mute Alerts: "Failed to schedule maintenance. Check your SWIS/Database connection and try again"

Updated April 5, 2018

Overview

This article discusses one possible solution to the error message: Failed to schedule maintenance. Check your SWIS/Database connection and try again.

unable mute alert1.png

 

This is accompanied by the following message in OrionWeb.log:

2018-04-02 02:26:33,567 [101] (62) ERROR SolarWinds.Orion.Web.Controllers.CoreController+<>c - (null)  System.ServiceModel.FaultException`1[SolarWinds.InformationService.Contract2.InfoServiceFaultContract]: Orion.AlertSuppression.SuppressAlerts failed, check fault information.

One or more errors occurred. (Fault Detail is equal to InfoServiceFaultContract [ System.AggregateException: One or more errors occurred. ---> SolarWinds.Data.Providers.DPA.V3.Federation.DpaDownException: DPA server with ID: 4 , Uri https://10.10.10.10:8124/iwc/service...rmationService  is down.

 

Environment

  • NPM 12 +
  • Orion Core 2016.x +
  • Any SW Product integrated with DPA 10.2.313

 

Cause 

  • Issue with the integration of DPA with the Orion Platform.

 

Resolution

  • Upgrade any DPA servers to DPA 10.2.579 or up 
  • or 
  • If you have access to the Orion Web Console, you'll need to re-integrate DPA:
    1. Log in to the Orion Web Console, and navigate to Settings > All Settings.

    2. Under Product Specific Settings, go to Database Performance Analyzer.

    3. Click 'Manage DPA Servers'.

    4. This page will list your DPA servers. Under the 'ACTION' column, there is a trash can. Click this to remove the integration. 

    5. Click 'YES' to confirm removal of the integration. 

    6. Click 'Add DPA Server'.

    7. Enter the DPA server details (DPA server name/IP, admin credentials, etc.).

    8. Click 'test' to test the server credentials, then click 'INTEGRATE' to finish.
       

  • If you do not have access to the Orion Web Console, you can break the integration using the backend Orion Database. Please see the following article: Remove integration with a DPA server manually.

 

 

 

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