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Home > Success Center > Orion Platform > Orion - Knowledgebase Articles > RabbitMQ stops on the Main Polling Engine and generates Orion Web Console issues

RabbitMQ stops on the Main Polling Engine and generates Orion Web Console issues

Updated July 30, 2018

Overview

The RabbitMQ service stops on the Main Polling Engine and generates issues with the Orion Web Console, such as missing menus or events that do not trigger an alert.

If you start the RabbitMQ service, it starts momentarily and then shuts down, generating issues with the Core Business Layer and Information Service version 3.

Environment

  • NPM 12.2
  • Orion Platform 2018.1
  • Microsoft Windows Server 2012 R2

Cause

Corrupted recovery dets file. The file size displays as 0 bytes in size, causing RabbitMQ to fail when started.

The log file displays the following:

Error in C:\ProgramData\Solarwinds\Orion\RabbitMQ\log, "rabbit@HOSTNAME.log":
17-Jul-2018::10:17:04 ===
Error description:
{could_not_start,rabbit,
{{badmatch,
{error,     
{{{badmatch,
{error,
{not_a_dets_file,"c:/PROGRA~3/SOLARW~1/Orion/RabbitMQ/db/RABBIT~1/recovery.dets"}}}

Resolution

Enable the RabbitMQ server to perform a correct boot-up sequence to allow the service to run. 

  1. Log in to the server. 
  2. Go to:
    C:\ProgramData\Solarwinds\Orion\RabbitMQ\db\rabbit@HOSTNAME-mnesia
  3. Copy the recovery dets file to your desktop.
  4. Open the Orion Service Manager and restart the RabbitMQ service.
  5. Verify that the recovery.dets file was recreated. The file should be about 6KB in size.
 
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