Submit a ticketCall us

whitepaperYour VM Perplexities Called, and They Need You to Read This.

Virtualization can give you enormous flexibility with future workloads and can be a key enabler for other areas, like cloud computing and disaster recovery. So, how can you get a handle on the performance challenges in your virtual environment and manage deployments without erasing the potential upside? Learn the four key areas you need to be focusing on to help deliver a healthy and well-performing data center.

Get your free white paper.

Home > Success Center > Orion Platform > Orion - Knowledgebase Articles > Orion Configuration Wizard generates an error

Orion Configuration Wizard generates an error

Updated January 11, 2019

Overview

When you run the Orion Configuration Wizard, the following message similar to the following displays:

Website configuration failed: Access to the path 'C:\Program Files (x86)\SolarWinds\
Orion\Information Service\3.0\SolarWinds.ADM.Contract.dll' is denied.

Environment

  • All Orion Platforms
  • Any files in the Program Files (x86) or Inetpub directory

Cause

A running process locked the file.

Resolution

Open the Windows Resource Monitor and terminate the process.

  1. Open a Run box and execute:
    resmon.exe
  2. Click the CPU tab.
  3. Under Associated Handles, locate the locked file. For example, SolarWinds.ADM.Contract.dll as shown below.
    monitor2.png
  4. Terminate the process. 
  5. Search for the file again, verifying that no other processes are accessing the file.
  6. Run the Orion Configuration Wizard again. 

 

 

 

Last modified

Tags

Classifications

Public