Submit a ticketCall us

Training ClassSign up for Network Performance Monitor (NPM) and Scalability instructor-led classes

Attend our instructor-led classes, provided by SolarWinds® Academy, to discuss the more advanced monitoring mechanisms available in NPM as well as how to tune your equipment to optimize its polling capabilities. NPM classes offered:
NPM Custom Monitoring and Polling
Orion Platform Scalability

Reserve your seat.

Home > Success Center > Orion Platform > Orion - Knowledgebase Articles > SolarWinds Information Service (SWIS) issues

SolarWinds Information Service (SWIS) issues

Updated January 14, 2019

Overview

When running an Orion Platform product, you might encounter the following SWIS issues:

  • SWIS issues and Core BL not starting - Plugin "Core Business Layer" failed to start -- Unknown provider Orion.
  • Primary poller is up but the additional polling engine is displayed as down in the polling engines window.
  • When you edit a node connected through a remote polling engine and test the login credentials, the following error message appears:

    There is no endpoint listening on port 17777 and shows an undefined 500 Inner Exception

  • In the Orion.InformationService.log, you can find the following error:
    2017-10-12 09:02:11,861 [20] ERROR SolarWinds.InformationService.Core.SchemaLoader - 
    (null) (null)  Error initializing or starting an instance of provider 'SolarWinds.Data.Providers.Orion.OrionDataProvider, SolarWinds.Data.Providers.Orion.v3'
    System.InvalidOperationException: Function AlarmLevelToDatabaseInstanceStatus is implemented by SolarWinds.Data.Providers.DPA.V3.Functions.AlarmLevelToDatabaseInstanceStatusExpression, Plugins/SolarWinds.Data.Providers.DPA.V3, but that type could not be found.
       at SolarWinds.InformationService.Addons.DataProviderFunctionInfo..ctor(IFunctionElement functionElement)
       at SolarWinds.InformationService.Addons.DataProvider.RegisterFunctions()
       at SolarWinds.InformationService.Addons.DataProvider.Start(IServiceHost serviceHost)
       at SolarWinds.InformationService.Core.SchemaLoader.CreateProviders(SchemaLoadResult loadResult)

Environment

  • NPM

  • SAM

  • SRM

  • NCM

Cause 

The set of SWISv3 schemas does not match the installed libraries.

Resolution

To resolve the SWIS issues, complete the following steps:

  1. Stop all Orion services.
  2. Uninstall SWISv3.
    1. Open Programs and Features, right-click SolarWinds Information Service, and select Uninstall.
    2. Complete the wizard to uninstall the service.
  3. Delete SWISv3 folder in Orion installation.
    By default, the folder is located at C:\ProgramData\Solarwinds\InformationService\v3.0.
  4. Install SWISv3. 
    Go to ProgramData/SolarWinds/Installers, and run InformationService.msi.

    The msi used to reinstall SWIS may have a different filename, depending on the Orion Platform version. For example, the file to run for Orion Platform 2018.4 products is SWIS-2017.5.0.2118-InformationService.msi.

  5. Repair the installation of all installed Orion Platform products. See Repair the installation of an Orion Platform product with Windows Control Panel and the SolarWinds Configuration Wizard.

Suggested Tags:  SWIS not working CORE BL <g class="gr_ gr_44 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling multiReplace" data-gr-id="44" id="44">wont</g> start

 

Reason for Rework or Feedback from Technical Content Review:

 

 

Last modified

Tags

Classifications

Public