Submit a ticketCall us

AnnouncementsAre You “Flying Blind?”

When it comes to your complex IT infrastructure, you want to ensure you have a good grasp of what’s going on to avoid any fire drills that result from guesswork. Read our white paper to learn how proactively monitoring your IT environment can help your organization while giving you peace of mind.

Get your free white paper.

Home > Success Center > Orion Platform > Orion - Knowledgebase Articles > Enable SHA for Orion Platform products

Enable SHA for Orion Platform products

Updated: April 25, 2017

Overview

If SHA is not enabled, the Orion Web Console may not start and agents may not be able to communicate correctly with the polling engine.

Environment

Any product running on the Orion Platform, such as: 

  • NPM 12.1 and earlier
  • SAM 6.4 and earlier

Cause 

Products running on SolarWinds Orion Platform must have SHA enabled in the registry.

Resolution

SolarWinds strongly recommends that you back up your registry before making any edits to your system registry. You should only edit the registry if you are experienced and confident in doing so. Using a registry editor incorrectly can cause serious issues with your operating system, which could require you to reinstall your operating system to correct them. SolarWinds cannot guarantee resolutions to any damage resulting from making registry edits.

 

  1. Log in as an administrator to the computer running your Orion server, Additional Polling Engine, or Additional Web Server.
  2. Open the Registry Editor.
  3. Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Hashes\SHA.  
  4. Set the Enabled value to 0xffffffff. It cannot be 0x0.

SHA is correctly enabled and the Orion Web Console and Orion agents should work as expected.

 

 

Last modified

Tags

Classifications

Public