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Home > Success Center > Orion Platform > Orion - Knowledgebase Articles > Configuration Wizard error after running an upgrade or hotfix

Configuration Wizard error after running an upgrade or hotfix

Created by Michael Perez, last modified by Steve.Hawkins on Oct 17, 2017

Views: 323 Votes: 2 Revisions: 10

Overview

The following error displays when you run the Orion Configuration Wizard after an upgrade or hotfix:

Database configuration failed:

  • Exception while configuring Orion Core Services component Orion Database. A specified logon session does not exist. It may already have been terminated

Environment

All Orion products

Cause 

SolarWinds Orion certificate issue.

Resolution

Delete the SolarWinds Orion certificate

  1. Delete the SolarWinds-Orion certificate from Personal Certificates on the local machine using MMC.exe. See Delete a Certificate for details.
  2. Delete the certificate from the ServerCertificates table in the Orion database.
  3. Run the Configuration Wizard again.  

 

For Personal Certificates

  1. Open the Microsoft Management Console (MMC).
    Open a Run window and execute:
    mmc
  2. Click File > Add/Remove Snap-In.
  3. Click Add > Certificates and then click OK.
  4. Select Computer Account > Local Computer and proceed.
  5. Right-click and delete the bad certificate.
  6. With the MMC and the Certificates snap-in open, double-click Certificates (Local Computer) in the center window.
  7. Right-click the Personal Certificates Store (folder) and select ALL TASKS > Import.
  8. Complete the Certificate Import Wizard to import your PFX file.
  9. Enter the password used to export the certificate to a PFX file.
  10. (Optional) Select Mark this key as exportable.
  11. When prompted, choose to automatically place the certificates in the certificate stores based on the type of the certificate
  12. Click Finish to close the certificate wizard.
  13. Close the MMC console. If prompted, it is not required to save the changes made to the MMC console.

 

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