Submit a ticketCall us

WebinarUpcoming Webinar: How Help Desk and Remote Support Pays for Itself

Learn how help desk software can simplify ticketing management, allow you to track hardware and software assets, and accelerate the speed of IT support and service delivery. Gain insights on how remote support tools allow your IT team to maximize their efficiency and ticket resolution by expediting desktop troubleshooting, ultimately helping keep end-users happy and productive.

Register here.

Home > Success Center > Orion Platform > Orion - Knowledgebase Articles > Complex Alerts in SolarWinds Orion products - Reset Condition Variables not Populating for Alerts on Multiple Objects

Complex Alerts in SolarWinds Orion products - Reset Condition Variables not Populating for Alerts on Multiple Objects

Updated 10/17/2017

Overview

This article provides an overview of a potential solution for setting up reset actions for complex alerts. A complex alert requires a minimum number of objects to trigger on, and by design, they do not display out-of-the-box variables on reset.

Environment

  • Any Orion Platform product.

 

Cause 

In a normal alerting scenario, the history of the object that triggered the alert is retained, and you can view the trigger history for the alert, even after the alert is cleared from active alerts. 

However, for complex alerts that trigger on multiple objects, historical data is not retained for the objects that triggered the alert. As a result, when the alert resets, no automated variables can be populated with the objects that triggered the alert.

Resolution

The only known workaround for this is to use a CUSTOM SQL/SWQL variable, and manually query the column for each object.

This also requires the alert itself to only trigger on specific objects.

Note: SolarWinds cannot offer assistance in creating the custom SQL/SWQL variable.

 

Last modified

Tags

Classifications

Public