Submit a ticketCall us

AnnouncementsTHWACKcamp 2018 is here

2018 is the seventh year for THWACKcamp™, and once again we’ll be live October 17 – 18 with packed session tracks covering everything from network monitoring and management, to change control, application management, storage, cloud and DevOps, security, automation, virtualization, mapping, logging, and more.

Register for online sessions.

Home > Success Center > Orion Platform > Orion - Knowledgebase Articles > Business Layer Error - Could not load file or assembly SolarWinds.Orion.Core.Discovery

Business Layer Error - Could not load file or assembly SolarWinds.Orion.Core.Discovery

Created by Harry Griffiths, last modified by Rodim Suarez_ret on Jul 07, 2016

Views: 1,917 Votes: 0 Revisions: 5

Updated

Overview

The following error appears when inspecting the business layer.log file (C:\ProgramData\SolarWinds\Logs\Orion\BusinessLayerHost.log):

System.IO.FileNotFoundException: Could not load file or assembly
'SolarWinds.Orion.Core.Discovery, Version=2015.1.35100.9209, Culture=neutral,
PublicKeyToken=null' or one of its dependencies.
The system cannot find the file specified.
File name: 'SolarWinds.Orion.Core.Discovery, Version=2015.1.35100.9209,
Culture=neutral, PublicKeyToken=null'

Environment

NPM 11.5.3

Cause 

The SolarWinds.Orion.DiscoveryPlugin.dll file was not moved to the correct directory during last upgrade.

This could be due to an antivirus or other scanning software interfering or permissions on the folders.

Resolution

  1. Stop all Orion services using Orion Service Manager.

  2. Manually copy the SolarWinds.Orion.Core.Discovery.Plugin.dll to the correct directory.
    It can be found here: Volume:\program files x86\SolarWinds\Orion\Discovery

  3. Copy it to the root directory: Volume:\program files x86\SolarWinds\Orion

  4. Start all Orion services using Orion Service Manager.

 

Last modified

Tags

Classifications

Public