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Home > Success Center > Orion Platform > Orion - Knowledgebase Articles > Agent polling fails after upgrading to NPM 12.3 and SAM 6.7

Agent polling fails after upgrading to NPM 12.3 and SAM 6.7

Updated October 4, 2018

Overview

After you upgrade the primary Orion Platform server to SAM 6.7 and NPM 12.3, agent polling fails.

Environment

  • SAM 6.7
  • NPM 12.3

Cause

The primary Orion Platform server was not rebooted after the upgrade. As a result, the TCP connections and the agent management service dependency of Windows Event Logging were not refreshed.  

Agent logging may display the following message in the AgentManagement.Service.log file(s) located at C:\ProgramData\Logs\AgentManagement:

INFO  SolarWinds.AgentManagement.Messaging.Core.Service.Server.WebSocketsServer - 
Attempt to connect to WebSockets endpoint from <IPADDRESS> does not have proper 
ClientId parameter. Connection won't be registered. Value: 

Resolution

  1. Reboot the Primary Orion Platform server.
  2. Wait for Agent Polling to initiate and complete.
 

 

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