Submit a ticketCall us

WebinarUpcoming Webinar: How Help Desk and Remote Support Pays for Itself

Learn how help desk software can simplify ticketing management, allow you to track hardware and software assets, and accelerate the speed of IT support and service delivery. Gain insights on how remote support tools allow your IT team to maximize their efficiency and ticket resolution by expediting desktop troubleshooting, ultimately helping keep end-users happy and productive.

Register here.

Home > Success Center > Orion Platform > Orion - Knowledgebase Articles > Agent Not Collecting CPU or Memory but All Application Polling is working in SAM and NPM

Agent Not Collecting CPU or Memory but All Application Polling is working in SAM and NPM

Updated: October 26, 2017

Overview

This article discusses an issue some users may face when the SolarWinds Agent does not collect CPU or Memory but all Application Polling is working as expected.

 

Environment

  • SAM 6.2.4
  • NPM 12.0
  • Orion Core 2016.1

Cause 

When the agent gets registered to Orion with IP that is not one agent's local IP addresses (typical for NAT scenarios), core polling (basically all poller framework polling) does not work. Typical errors in job logs are similar to:

2016-09-05 11:25:51,939 [STP SmartThreadPool Thread #0] ERROR SolarWinds.Orion.Collector.Plugins.Pollers.PollersJob - (null)	 Poller V.Statistics.WMI.Windows for Entity:V:3 execution failed exception:System.ArgumentNullException: Value cannot be null.
Parameter name: credentials
   at SolarWinds.Net.WMI.WmiConnectionBuilder.BuildConnectionOptions(String targetComputer, String rootNamespace, NetworkCredential credentials, AuthenticationLevel authentication)
   at SolarWinds.Net.WMI.WmiConnectionBuilder.BuildConnection(String targetComputer, String rootNamespace, NetworkCredential credentials, Boolean autoCorrectedServerAddress, AuthenticationLevel authentication)
   at SolarWinds.Net.WMI.WmiConnectionBuilder.OpenConnection(WmiRequest wmiRequest)
   at SolarWinds.Orion.Core.Pollers.Volumes.WMI.VolumeProxyBase.DoPoll(GlobalSettingsBase globalSettings, SettingsBase nodeSettings, IEnumerable`1 pollerSettings, Credential credentials)
   at SolarWinds.Orion.Collector.Plugins.Pollers.PollerExecutor.DoPoll(GlobalSettingsBase globalSettings, SettingsBase nodeSettings, IEnumerable`1 pollerSettings, Credential credentials)

The system believes there are missing credentials, but real problem is that information about agent mode polling (for which credentials are not required) does not get propagated properly.

This is a bug that is resolved in more recent versions of NPM and SAM.

Resolution

To resolve this issue, upgrade to NPM 12.1 or SAM 6.4 (Orion Core 2017.1) or later as this bug has been fixed.
 

To workaround this issue:

  1. Log into the SolarWinds Server.
  2. Open Database Manager.
  3. Go to the Nodes Table and Find your Node in this table (select * from Nodes where NodeId = 2376).
  4. Click Enable Table Editing.
  5. Change the IP Address in this table to the Local IP address of the Agent (Run IPConfig on the Agent Node)
  6. From Services.msc on the Agent Node, restart the SolarWinds Agent Service. 

The Node will still be polled via the Agent but will use the Local Agent Address for Core Polling which is your CPU and Memory & will prevent the peculiar errors which are noted above.

 

 

Last modified

Tags

Classifications

Public