Submit a ticketCall us

WebinarWebinar: A checklist for planning your Network Performance Monitor (NPM) upgrade

Are you ready for your next upgrade? To help you plan smoothly, join this webcast to learn more about, SolarWinds® Orion® Installer, SolarWinds Upgrade Advisor, Upgrades Guides, Training Videos, and other resources available. We’ll share key upgrade planning considerations, lessons learned from customers with practical advice from SolarWinds Product Experts. We’ll also give practical tips to identify the estimated time needed and resources, how to prepare the business and IT staff for changes, ways to plan for required system changes, and more.

Register now.

Home > Success Center > Orion Platform > JavaScript error when assigning a node to WMI or SNMP polling

JavaScript error when assigning a node to WMI or SNMP polling

Updated July 2, 2018

Overview

When you assign a node to WMI or SNMP polling, the following JavaScript error displays:

error:Sys.WebForms.PageRequestManagerServerErrorException Sys.WebForms.PageRequestManagerServerErrorException: Index must be within the bounds of the List.
Parameter name: index 

error.png

This error could not be found in the OrionWeb.log file. However, the following error was recorded in the file:

2018-06-06 07:38:33,836 [40] (11) ERROR SolarWinds.Orion.Web.NodePropertyPluginManager - (null)  Failed to load plugin Control for node properties plugin NCMNodeProperties from path /Orion/NCM/Admin/Nodes/NodeProperties.ascx. Details: System.Web.HttpCompileException (0x80004005): C:\InetPub\SolarWinds\Orion\NCM\Admin\Nodes\NodeProperties.ascx.cs(1669): error CS0117: 'CliServiceContainer' does not contain a definition for 'GetContainer'
   at System.Web.Compilation.BuildManager.CompileWebFile(VirtualPath virtualPath)

Environment

  • Orion Platform 2018.2
  • NPM 12.3
  • SAM 6.6.1

You can verify the version of your installed software in Orion Diagnostics or in the black banner at the bottom of your Orion Platform home page.

Cause 

The Orion deployment is running incompatible product versions. In this issue, the NCM software version is older than the Orion Platform and NPM versions. 

Resolution

  1. Back up your Orion database.
  2. Create a snapshot of your libraries. 
  3. Log in to the SolarWinds Customer Portal. 
  4. Download the latest NCM version. If possible, use the online installer to apply any available hotfixes.
  5. Run the Orion installer.  
    If the installer displays an error with the incompatible versions, note the incompatible products and releases. The products that need to be uninstalled should the products with older release versions.
    If the installer does not display an error, STOP. Incompatible versions may not be the issue. 
  6. Open the Orion Service Manager and stop the Orion services
    If any services automatically restart, stop the services and configure these services to start manually. 
  7. In Programs and Features, uninstall the product(s). Do not run the Configuration Wizard.
  8. Make sure that Orion services are still stopped. 
    If the Orion services are running, configure these services to start up manually.
  9. Rerun the Orion installer. 
    In the screen that prompts you to install the products, make sure that you select all programs that you uninstalled in a previous step..
  10. Run the Configuration Wizard using an administrator account or a local account (recommended).
 

 

Last modified

Tags

Classifications

Public