Submit a ticketCall us

Systems Monitoring for Dummies
Our new eBook will teach you the fundamentals and help you create monitors and alerts that are effective, meaningful, and actionable. Monitoring is more than a checkbox on your to-do list. This free eBook will give you practical advice to help you succeed in all aspects of monitoring – discovery, alerting, remediation, and troubleshooting. Don’t miss out on this indispensable resource for newbies, experienced IT pros, and everyone in between. Register Now.

Home > Success Center > Orion Platform > Cannot connect to an SQL server using Windows authentication when specifying a machine name

Cannot connect to an SQL server using Windows authentication when specifying a machine name

Updated August 9, 2017

Overview

When specifying a machine name in your Windows credentials for your SQL server, such as hostname\administrator,  you may receive an error like the following:

Can not connect to the SQL Server. The original error is: Connection Timeout Expired. The timeout period elapsed while attempting to consume the pre-login handshake acknowledgement. This could be because the pre-login handshake failed or the server was unable to respond back in time. The duration spent while attempting to connect to this server was - [Pre-Login] initialization = 18066; handshake = 14340;

Environment

Any product running on Orion Platform version 2017.3, such as:

  • NPM 12.2
  • NCM 7.7

Cause 

This generally occurs when your Orion server and SQL server are placed on different subnets and the SQL server hostname cannot be resolved by the Orion server.

Resolution

You can resolve this issue in multiple ways.

Resolve this locally to the Orion server

You will need to repeat one or both methods on any other Orion servers you create.

Resolve this for multiple Orion servers

Create a DNS record for the SQL server's machine name.

 

Disclaimer: Please note, any content posted herein is provided as a suggestion or recommendation to you for your internal use. This is not part of the SolarWinds software or documentation that you purchased from SolarWinds, and the information set forth herein may come from third parties. Your organization should internally review and assess to what extent, if any, such custom scripts or recommendations will be incorporated into your environment.  You elect to use third party content at your own risk, and you will be solely responsible for the incorporation of the same, if any.

 

Last modified

Tags

Classifications

Public