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Home > Success Center > Network Topology Mapper (NTM) > Test SNMP communication with a device

Test SNMP communication with a device

Created by Chris Foley, last modified by John Wallace on Oct 04, 2016

Views: 1,293 Votes: 2 Revisions: 5

Overview

When NTM fails to provide a role for a device and marks it as an ICMP or Unidentified device, it is normally because SNMP communication between NTM and the device in question is failing.  This article explains how to test SNMP Communication using the SNMPWalk tool included with NTM.

Environment

  • All NTM versions 
  • All Windows versions 

Cause

The issue is caused by any of the following SNMP Communication failures:

  • Wrong SNMP Community string.  This string is case-sensitive.
  • The NTM host has not been added the target device's allowed host list in its SNMP Properties.
  • The SNMP queries are being blocked.  Check any firewalls blocking port 161/UDP.

Resolution

1. Run the following executable:

C:\Program Files\SolarWinds\Network Topology Mapper\SnmpWalk\SnmpWalk.exe

 

2. Enter the IP address and SNMP community string for the Device.

3. Leave the OID as and click Scan.

4. Save the results to a file on your desktop.

5. Open the file in a text editor.

 

Notes:

  • If SNMPWalk failed with a timeout, it is because the SNMP query did not receive a response.
  • If SNMPWalk completed but failed the populate the file, it is normally because SNMPWalk received a response but the response did not contain any SNMP information.

 

 

 

 

Last modified
10:08, 4 Oct 2016

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