Submit a ticketCall us

Don’t fall victim to a ransomware attack
Backups are helpful, but sometimes that’s not enough to protect your business against ransomware. At our live webcast we will discuss how to protect against ransomware attacks with SolarWinds® Patch Manager and how to leverage log data to detect ransomware. Register now for our live webcast.

Home > Success Center > Network Performance Monitor (NPM) > Website will not load: Orion module engine unable to talk to swis v2 after installing Web Companion by Lavasoft

Website will not load: Orion module engine unable to talk to swis v2 after installing Web Companion by Lavasoft

Updated April 5th, 2016

Overview

This article goes over an issue that can occur after installing Web Companion by Lavasoft where all the services are started and are up and running, but the module engine service (businesslayer host) is unable to communicate with SWIS v2, even though the Information Services are all started up.

 

Web Companion gets bundled with some third party applications such as Filezilla.

 

The following error occur in the BusinessLayerhost.log file when attempting to talk to swis v2:

2016-03-28 10:05:53,614 [8] WARN  SolarWinds.Orion.Core.Common.ServiceHelper - Waiting for SWIS v2.0 start. Attempt 14, exception message: "Could not connect to net.tcp://server:17777/SolarWinds/InformationService/Orion/certificate. The connection attempt lasted for a time span of 00:00:02.0114712. TCP error code 10061: No connection could be made because the target machine actively refused it [::1]:17777. "

 

2016-03-28 10:14:01,665 [8] WARN  SolarWinds.Orion.Core.Common.InformationServiceConnectionProvider - Connection via certificate could not be created.
System.TimeoutException: The open operation did not complete within the allotted timeout of 00:01:00. The time allotted to this operation may have been a portion of a longer timeout. ---> System.TimeoutException: The socket transfer timed out after 00:01:00. You have exceeded the timeout set on your binding. The time allotted to this operation may have been a portion of a longer timeout. ---> System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond
   at System.Net.Sockets.Socket.Receive(Byte[] buffer, Int32 offset, Int32 size, SocketFlags socketFlags)
   at System.ServiceModel.Channels.SocketConnection.ReadCore(Byte[] buffer, Int32 offset, Int32 size, TimeSpan timeout, Boolean closing)
   --- End of inner exception stack trace ---
   at System.ServiceModel.Channels.SocketConnection.ReadCore(Byte[] buffer, Int32 offset, Int32 size, TimeSpan timeout, Boolean closing)
   at System.ServiceModel.Channels.SocketConnection.Read(Byte[] buffer, Int32 offset, Int32 size, TimeSpan timeout)
   at System.ServiceModel.Channels.DelegatingConnection.Read(Byte[] buffer, Int32 offset, Int32 size, TimeSpan timeout)
   at System.ServiceModel.Channels.ConnectionUpgradeHelper.InitiateUpgrade(StreamUpgradeInitiator upgradeInitiator, IConnection& connection, ClientFramingDecoder decoder, IDefaultCommunicationTimeouts defaultTimeouts, TimeoutHelper& timeoutHelper)
   at System.ServiceModel.Channels.ClientFramingDuplexSessionChannel.SendPreamble(IConnection connection, ArraySegment`1 preamble, TimeoutHelper& timeoutHelper)
   at System.ServiceModel.Channels.ClientFramingDuplexSessionChannel.DuplexConnectionPoolHelper.AcceptPooledConnection(IConnection connection, TimeoutHelper& timeoutHelper)
   at System.ServiceModel.Channels.ConnectionPoolHelper.EstablishConnection(TimeSpan timeout)
   at System.ServiceModel.Channels.ClientFramingDuplexSessionChannel.OnOpen(TimeSpan timeout)
   --- End of inner exception stack trace ---

Server stack trace: 
   at System.ServiceModel.Channels.ClientFramingDuplexSessionChannel.OnOpen(TimeSpan timeout)
   at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
   at System.ServiceModel.Channels.ServiceChannel.OnOpen(TimeSpan timeout)
   at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
   at System.ServiceModel.Channels.CommunicationObject.Open()

Exception rethrown at [0]: 
   at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
   at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
   at System.ServiceModel.ICommunicationObject.Open()
   at SolarWinds.InformationService.Contract2.InfoServiceProxy.Open()
   at SolarWinds.InformationService.InformationServiceClient.InformationServiceConnection.Open()
   at SolarWinds.Orion.Core.Common.InformationServiceConnectionProvider.CreateConnectionForCertificate(String targetServer)
   at SolarWinds.Orion.Core.Common.InformationServiceConnectionProvider.CreateSystemConnectionToMainHost()

Environment

NPM 10 and later

Cause 

The issue is caused by an application called Web Companion by Lavasoft. The application blocks the communication of the Orion module engine service with the the Information services through a local TCP connection via port 17777.

 

Currently, there is no workaround to allow Orion to function with the application installed to the server. Removal of the application is the only current way to allow Orion to be able to communicate with its other services through local TCP ports.

Resolution

  1. Open Add\Remove Programs on the server.
  2. Find Web Companion by Lavasoft.
  3. Uninstall the application.
Last modified
14:38, 12 Jun 2017

Tags

Classifications

Public