Submit a ticketCall us

Webinar: Web Help Desk for HR, Facilities and Accounting Departments
This webinar will focus on use cases for HR, Facilities and Accounting.

Having a unified ticketing and asset management system for all the departments in your company can provide end-users with a seamless experience and make things easier for your IT team. Yet, with different business tasks and objectives, many departments don’t fully understand the capabilities of Web Help Desk and how the software can be customized for effective use in their departments.
Register Now.

Home > Success Center > Network Performance Monitor (NPM) > Website Configuration failed: Access to the path is denied

Website Configuration failed: Access to the path is denied

Overview

This article describes the issue about the following error: 

Access to the path "D:\Program Files (x86)\SolarWinds\Orion\Interfaces\SolarWinds.Interfaces.Strings.dll" is denied

Upon visiting the website, you receive the following error:

 

Unexpected Website Error

Could not connect to net.tcp://localhost:17777/SolarWinds/InformationService/v3/Orion/certificate. The connection attempt lasted for a time span of 00:00:02.0156895. TCP error code 10061: No connection could be made because the target machine actively refused it 127.0.0.1:17777.

 

The saved error report shows the following:

 

URL: http://172.168.0.1:80/Orion/Admin/Default.aspx
Referrer: http://172.168.0.1:80/Orion/Admin/Default.aspx
Message: Could not connect to net.tcp://localhost:17777/SolarWinds/InformationService/v3/Orion/certificate. The connection attempt lasted for a time span of 00:00:02.0156895. TCP error code 10061: No connection could be made because the target machine actively refused it 127.0.0.1:17777.
ErrorSite: mscorlib.RealProxy.HandleReturnMessage
ErrorType: System.ServiceModel.EndpointNotFoundException

Stack:

Server stack trace:
at System.ServiceModel.Channels.SocketConnectionInitiator.Connect(Uri uri, TimeSpan timeout)
at System.ServiceModel.Channels.BufferedConnectionInitiator.Connect(Uri uri, TimeSpan timeout)
at System.ServiceModel.Channels.ConnectionPoolHelper.EstablishConnection(TimeSpan timeout)
at System.ServiceModel.Channels.ClientFramingDuplexSessionChannel.OnOpen(TimeSpan timeout)
at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
at System.ServiceModel.Channels.ServiceChannel.OnOpen(TimeSpan timeout)
at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
at System.ServiceModel.Channels.CommunicationObject.Open()

Exception rethrown at [0]:
at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
at System.ServiceModel.ICommunicationObject.Open()
at SolarWinds.InformationService.Contract2.InfoServiceProxy.Open()
at SolarWinds.InformationService.InformationServiceClient.InformationServiceConnection.Open()
at SolarWinds.Orion.Core.Common.InformationServiceConnectionProvider.CreateConnectionForCertificateV3(String targetServer)
at SolarWinds.Orion.Core.Common.InformationServiceConnectionProvider.CreateSystemConnectionV3(String targetServer)
at SolarWinds.Orion.Core.Common.PackageManager.SwisPackageManager.<ReadPackageInfos>d__6.MoveNext()
at System.Linq.Buffer`1..ctor(IEnumerable`1 source)
at System.Linq.Enumerable.ToArray[TSource](IEnumerable`1 source)
at SolarWinds.Orion.Core.Common.PackageManager.SwisPackageManager.IsPackageInstalled(String packageId)
at ASP.orion_admin_default_aspx.OnInit(EventArgs e)
at System.Web.UI.Control.InitRecursive(Control namingContainer)
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
-- Inner Exception
  Message: No connection could be made because the target machine actively refused it 127.0.0.1:17777
  Type: System.Net.Sockets.SocketException
  Stack:
at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)
  at System.Net.Sockets.Socket.Connect(EndPoint remoteEP)
  at System.ServiceModel.Channels.SocketConnectionInitiator.Connect(Uri uri, TimeSpan timeout)

Environment

All versions of NPM

Cause 

This issue occurs when another user account is using the same application.

Resolution

  1. Open Task Manager.
  2. Under Users Tab, log off all the other Users logged on or restart the server.
  3. Re-Run the Configuration Wizard.
Last modified
00:02, 23 Jun 2016

Tags

Classifications

Public