Submit a ticketCall us

Looking to compare latest NPM features with previous versions of NPM?
The NPM new feature summary offers a comparison of new features and improvements offered with this release.

 

Home > Success Center > Network Performance Monitor (NPM) > Version mismatch error when installing a new additional poller

Version mismatch error when installing a new additional poller

Created by Matthew Lamb, last modified by Rodim Suarez on Aug 16, 2016

Views: 31 Votes: 0 Revisions: 6

Updated August 16, 2016

Overview

This article goes over an issue that can occur when the primary poller is using NPM 11.5.2 or earlier with NCM 7.4.2 installed. When attempting to install NPM 11.5.2 on a new additional poller, you receive this error:

The version of Orion Core installed on your primary Orion server is newer than the versions of Orion Core that you are trying to install on your additional server.

You must install the Additional Poller or Additional Web Server of a module that provides the newer Orion Core on your additional server first.

For the recommended module installation order, see the documentation provided in the Additional Poller and Web Server Package.

 

 

Environment

  • Multiple pollers
  • NPM 11.5.2 and earlier
  • NCM 7.4.2

Cause 

When NCM 7.4.2 was installed on the primary poller, it installed the latest version of Core as well. Since the NPM 11.5.2 installer contains an older version of Core than what is installed on the primary poller, then the mismatch happens.

Resolution

  1. Install NCM 7.4.2 on the additional poller first.
  2. Install NPM 11.5.2 after NCM 7.4.3 is finished.

 

Last modified
20:18, 15 Aug 2016

Tags

Classifications

Public