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Home > Success Center > Network Performance Monitor (NPM) > Value cannot be null. Parameter name: userName

Value cannot be null. Parameter name: userName

Updated November 22, 2016

Overview

When attempting to add a Windows Active Directory or Group, the following error occurs:
Value cannot be null.
Parameter name: userName

Environment

  • Orion Core Services 2016.1 and later
  • NPM 12.0 and later
  • SAM 6.2.4 and later

Cause 

There is an LDAP authentication specified and enabled. It fails due to an attempt to use the Local Network Service Account to attempt to authenticate into LDAP.

Resolution

Resolution 1

Specify the credentials under the Specify credentials to access Active Directory or Local Domain section.

 

Resolution 2

  1. Disable LDAP integration via: Settings > Advanced AD Settings.
  2. Add your user or group.
  3. Re-enable LDAP integration. 

This option will only work if the Orion server is joined to the Domain.

 

Last modified
17:28, 17 Feb 2017

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