Submit a ticketCall us

Don’t fall victim to a ransomware attack
Backups are helpful, but sometimes that’s not enough to protect your business against ransomware. At our live webcast we will discuss how to protect against ransomware attacks with SolarWinds® Patch Manager and how to leverage log data to detect ransomware. Register now for our live webcast.

Home > Success Center > Network Performance Monitor (NPM) > VIM Hyper-V polling at 100% of its maximum rate

VIM Hyper-V polling at 100% of its maximum rate

Updated June 27, 2017

Overview

The VIM Hyper-V polling rate exceeds the threshold and displays the following message while the global polling rate is not affected:

100% of its maximum rate. Polling intervals increase if the polling rate exceeds 100% of the maximum rate.

Environment

VIM 2.x to 7.x

Cause

For VIM, there is a polling rate per polling engine which applies to each of the VMware ESX hosts or Hyper-V hosts. Each of them has a limit of 100, meaning a single polling engine can monitor up to 100 ESX and Hyper-V hosts on a default polling interval of 300 seconds. 

 

The displayed message may be encountered if either of the two types of virtualization exceeds the limit.

Resolution

  1. Distribute the excess hosts to additional polling engines if applicable.
  2. Double the capacity of the polling engine's polling rate by using a stackable polling engine.
  3. Increase the polling interval of the hosts from the default 5 minutes to a higher value, such as 15 or 20 minutes.
    Note: This step cannot be done via the Orion Web Console. Use the following query in Orion Database Manager:
    UPDATE [dbo].[VIM_PollingTaskTypes] SET PollingInterval = 1200 (Per Node)
    UPDATE [dbo].[VIM_PollingTasks] SET PollingInterval = 1200 (Global for new nodes)

 

 

Last modified
16:57, 26 Jun 2017

Tags

Classifications

Public