Submit a ticketCall us

Looking to compare latest NPM features with previous versions of NPM?
The NPM new feature summary offers a comparison of new features and improvements offered with this release.

 

Home > Success Center > Network Performance Monitor (NPM) > Unable to upgrade APE due to incompatible SRM module version

Unable to upgrade APE due to incompatible SRM module version

Created by Roger Lofamia, last modified by Steven Bansil on Jul 11, 2016

Views: 11 Votes: 0 Revisions: 2

Updated: July 11, 2016

Overview

This article provides solution on the issue when upgrading NPM on APE (Additional Polling Engine) server to version 12 detecting that the SRM version is incompatible.

 

Environment

  • NPM version 11.5.3
  • SRM version 6.1

 

Cause 

Even after uninstalling SRM 6.1 and rebooting the APE server the issue still persists. This is due to the SRM 6.1 registry remnant on the server registry.

 

Resolution

Warning: Make sure to back up your windows registry first before applying the solution.

  1. Log in on the APE server.
  2. Open windows registry by running regedit.exe.
  3. Go to the registry key HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432node\Solarwinds\Orion.
  4. Delete the SRM registry entry.
  5. Reboot the APE server and run the APE NPM 12 installer.

 

 

Last modified
00:01, 11 Jul 2016

Tags

Classifications

Public