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Home > Success Center > Network Performance Monitor (NPM) > Unable to receive email alerts even when SMTP test emails work

Unable to receive email alerts even when SMTP test emails work

Updated July 11, 2017

Overview

Alert emails are not sent even when SMTP test emails are working in the 'Manage SMTP' server settings.

The following error message is displayed when attempting to execute the alert email as a test.

Mailbox unavailable. The server response was: 5.7.60 SMTP; Client does not have permissions to send as this sender

The following error message is also found in the ActionsExecution.log file:

XXXX-XX-XX XX:XX:XX,XXX [181] ERROR SolarWinds.Orion.Core.Actions.Impl.Email.EmailMethodInvoker - (null)  Test for SMTP server (smtp.office365.com:587, SSL enabled, Authentication enabled) failed

XXXX-XX-XX XX:XX:XX,XXX [181] ERROR SolarWinds.Orion.Core.Actions.Impl.Email.EmailMethodInvoker - (null)  Test for SMTP server (smtp.office365.com:587, SSL enabled,
Authentication enabled) failed
System.Net.Mail.SmtpException: Mailbox unavailable. The server response was: 5.7.60 SMTP; Client does not have permissions to send as this sender
[BL2PR02MB2004.namprd02.prod.outlook.com]
   at System.Net.Mail.DataStopCommand.CheckResponse(SmtpStatusCode statusCode, String serverResponse)
   at System.Net.Mail.DataStopCommand.Send(SmtpConnection conn)
   at System.Net.Mail.SmtpConnection.OnClose(Object sender, EventArgs args)
   at System.Net.ClosableStream.Close()
   at System.Net.Mail.MailWriter.Close()
   at System.Net.Mail.SmtpClient.Send(MailMessage message)
   at SolarWinds.Orion.Core.Actions.Utility.Smtp.Clients.NativeSmtpClient.Send()
   at SolarWinds.Orion.Core.Actions.Impl.Email.EmailMethodInvoker.SendTestEmail(String args)

Environment

All Orion Platform environments

Cause 

This issue occurs when SolarWinds sends an email with a reply address that mismatches the user name and password combination configured in the SMTP server settings used by the affected alerts.

Resolution

Verify that the user name in the 'Edit SMTP Server' section matches the reply address in the 'Configure action: Send an Email/Page - Sender details - Reply Address' section of the alert trigger actions. This can be changed from either the SMTP server settings or the sender details on the alert email settings.

 

To change the default email action and change the settings for the SMTP server, see the following:

 

Refer to the following screenshots for more information.
Note: The serviceaccount@organization account is an example and is only used for the purpose of illustrating the fields that need to match. You may also only need to change one or more, but not all of these settings for the values to match. 

 

 

If you need to change the default sender details for all alerts at one time, see Update the sender email address on all alerts.

 

 

Last modified
17:11, 10 Jul 2017

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Public