Submit a ticketCall us

Webinar: Web Help Desk for HR, Facilities and Accounting Departments
This webinar will focus on use cases for HR, Facilities and Accounting.

Having a unified ticketing and asset management system for all the departments in your company can provide end-users with a seamless experience and make things easier for your IT team. Yet, with different business tasks and objectives, many departments don’t fully understand the capabilities of Web Help Desk and how the software can be customized for effective use in their departments.
Register Now.

Home > Success Center > Network Performance Monitor (NPM) > Unable to manage alerts in the Web Console

Unable to manage alerts in the Web Console

Updated August 29, 2017

Overview

Some users are not able to manage alerts in the web console. The page is blank.

 

Environment

  • Orion Platform 2016.1
  • Orion Platform 2016.2

Cause 

This can occur when there are Action Assignments for non-existing actions.

 

Similar error to the following located in the Orionweb.log:

ERROR NewAlertingService - (null)  Failed to retrieve alerts.
System.InvalidCastException: Cannot cast DBNull.Value to type 'System.Int32'. Please use a nullable type.
   at System.Data.DataRowExtensions.UnboxT`1.ValueField(Object value)
   at System.Data.DataRowExtensions.Field[T](DataRow row, String columnName)
   at NewAlertingService.<>c.<GetAlerts>b__4_9(DataRow x)
   at System.Linq.Enumerable.WhereSelectListIterator`2.MoveNext()
   at System.String.Join[T](String separator, IEnumerable`1 values)
   at NewAlertingService.GetAlerts(String property, String type, String value, String search)

Resolution

  1. Back up the ActionsAssignments DB table with data to avoid any risks.
  2. Run the following query which should delete obsolete action assignments:
DELETE FROM ActionsAssignments WHERE ActionID NOT IN (SELECT ActionID FROM Actions)
 

 

Last modified
09:37, 29 Aug 2017

Tags

Classifications

Public