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Home > Success Center > Network Performance Monitor (NPM) > Unable to integrate the Customer Portal account with the Orion Web Console through a proxy

Unable to integrate the Customer Portal account with the Orion Web Console through a proxy

Overview

The Customer Portal account cannot be integrated with the Orion Web Console when the Orion Server is connected to the Internet through a proxy.

Environment

  • NPM 11.5 and later
  • Orion Core 2015.1 and later

Resolution

Warning: 

  • SolarWinds strongly recommends that you only edit the SolarWinds.Orion.Core.BusinessLayer.dll.config file as instructed. Any additional modifications may result in system performance issues or may create an error state.
  • Save a copy of the original SolarWinds.Orion.Core.BusinessLayer.dll.config file to your local drive as a backup file, in case you need to roll back later.
     
  1. Open and edit the C:\Program Files (x86)\SolarWinds\Orion\SolarWinds.Orion.Core.BusinessLayer.dll.config file.
  2. Modify the following keys with your proxy details:
    • <add key="proxyAvailable" value="true" />
    • <add key="userName" value="username" />
    • <add key="password" value="password" />
    • <add key="proxyAddress" value="proxyServerAddress" />
    • <add key="proxyPort" value="proxyPortNumber" />
      Note: You must replace username, password, proxyServerAddress, and proxyPortNumber with the appropriate values for your proxy server.
  3. Save the file.
  4. Restart the Orion Module Engine
  5. You should now be able to integrate the Customer Portal account with the Orion Web Console successfully.

 

If the steps above do not resolve the issue. Please use the configuration below instead:

  1. Open and edit the C:\Program Files (x86)\SolarWinds\Orion\SolarWinds.Orion.Core.BusinessLayer.dll.config file.
  2. Modify the following keys with your proxy details:
    • <system.net> 
    • <defaultProxy enabled="true"> 
    • <proxy proxyaddress="http://<proxyServerAddress>:<proxyPortNumber>" bypassonlocal="true" /> 
    • </defaultProxy> 
    • </system.net>
      Note: You must replace proxyServerAddress, and proxyPortNumber with the appropriate values for your proxy server.
  3. Save the file.
  4. Restart the Orion Module Engine
  5. You should now be able to integrate the Customer Portal account with the Orion Web Console successfully.

Cause 

The Core Business Layer is responsible for Customer Portal integration and is currently not configured to connect to the Internet through a proxy. There are plans to move this configuration to the Web Console in the future.

Last modified
23:51, 22 Jun 2016

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