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Home > Success Center > Network Performance Monitor (NPM) > Trigger condition drop-downs are blank when editing alerts

Trigger condition drop-downs are blank when editing alerts

Overview

The drop-down menu is blank and nothing can be selected or typed manually in the trigger conditions after editing an existing alerts in web alerts.

Environment

NPM 11.5.0 or later

Cause 

As most alerts starting NPM 11.5 are web based, this usually happens if the IIS feature gets corrupted and needs to be recycled. This can also be because of issues with schema in swis. 

Resolution

  1. Stop all Orion services using the Orion Service Manager.
  2. Open Database manager and run the following queries against the DB:
    delete from pendingnotifications
    delete from subscriptions
  3. Run configuration wizard for all 3 components (DataBase, Website, Services)
  4. When completes and services are running again
  5. Try editing the alert again.

 

Another resolution is Resetting the IIS:

 

1. From the Orion server, open the command prompt as administrator
2. Type "iisreset"
 
There is a post in SolarWinds thwack about this issue and resetting IIS via command prompt resolved it. Please see the link below:

 

Note: You may also need to clear the ASP .NET cache as well. See https://support.solarwinds.com/Success_Center/Troubleshooting_Tools/Orion_Core_Troubleshooting_Guide_-_Website_Performance/Other_Time_is_High/How_to_Clear_.Net_Cache_Manually


https://thwack.solarwinds.com/thread/77180

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