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Home > Success Center > Network Performance Monitor (NPM) > There was an error while loading data for this resource. Timeout expired. The timeout period elapsed

There was an error while loading data for this resource. Timeout expired. The timeout period elapsed

Updated July 3, 2017

Overview

Data is not displayed and the following error is returned when running a Min/Max/Average bps In/Out report in Export mode, or from Report Manager for a large data set:

There was an error while loading data for this resource.
Timeout expired. The timeout period elapsed.

 

Note: The following are examples of the view and the report without the error. 

Export view example:

 

Report example:

 

Environment

NPM 12 and later

Cause 

The SQL timeout in the NetPerfmon configuration file was set to 60 seconds. The time elapsed and was not enough for the large amount of data that was being pulled to complete. 

Resolution

  1. Go to C:\Program Files (x86)\SolarWinds\Orion.
  2. Open the SWNetPerfMon.DB file.
  3. Locate the following settings at the bottom of the SWNetPerfMon.DB text file these are the default settings that should be set:
    !    Connection timeout in seconds
    Timeout=20
    !
    !    Database Command timeout in seconds
    CommandTimeout=90

    !
    ! SqlCommand.CommandTimeout in seconds
    SqlCommandTimeout=0
  4. Adjust the SqlCommandTimeout=0 setting to allow enough time for the command to complete.
 

 

Last modified
17:25, 2 Jul 2017

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Public