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Home > Success Center > Network Performance Monitor (NPM) > There was an error retrieving data from SolarWinds Information Service

There was an error retrieving data from SolarWinds Information Service

Created by John Salvani, last modified by MindTouch on Jun 23, 2016

Views: 1,048 Votes: 6 Revisions: 8

Overview

When opening any objects, such as http://<NPM server IP>:<port>/Orion/NetPerfMon/NodeDetails.aspx?NetObject=N:62, the following error appears:

 

There was an error retrieving data from SolarWinds Information Service

 

 

The following information shows in the Event logs:

 

Time: 11/04/2015 10:18:08.5040
Server: Microsoft-IIS/8.5
Pipeline: Integrated
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/46.0.2490.80 Safari/537.36
Error Instance: 5ff36bea6da84b4d8a874c8152610a79
User: admin
URL: http://npm1:8787/Orion/NetPerfMon/No...NetObject=N:44
Referrer: http://npm1:8787/Orion/NetPerfMon/No...NetObject=N:44
Message: Error: A query to the SolarWinds Information Service failed.
ErrorSite: OrionWeb.InformationServiceProxy.PropagateException
ErrorType: SolarWinds.Orion.Web.InformationService.SwisQueryException
Stack:
at SolarWinds.Orion.Web.InformationService.InformationServiceProxy.PropagateException(Exception e)
at SolarWinds.Orion.Web.InformationService.InformationServiceProxy.Query(String query, IDictionary`2 parameters, Boolean useSeparateExecutionContext)
at SolarWinds.Orion.Web.InformationService.InformationServiceProxy.Query(String query, IDictionary`2 parameters)
at SolarWinds.Netflow.Web.Reporting.SWISHelper.<>c__DisplayClass1.<Query>b__0()
at SolarWinds.Netflow.Web.Reporting.SWISHelper.Query(String swql, Dictionary`2 parameters, Func`1 getData)
at SolarWinds.Netflow.Web.Reporting.SWISHelper.Query(String swql, Dictionary`2 parameters, IInformationServiceProxy proxy)
at SolarWinds.Netflow.Web.Reporting.SWISHelper.Query(String swql, Dictionary`2 parameters)
at SolarWinds.Netflow.Web.Reporting.TimePeriodUiDbInfo..ctor(DateTime startTime, DateTime endTime, Boolean trimStartTimeEndTime)

Environment

NPM version 11.5

Cause 

The Information service is corrupted and subscription is not cleared out.

Resolution

 

Resolution 1

Notes: 

  • ​Consult your System Administrator before performing the following procedure. 
  • Log in as Local Administrator and not as Domain Administrator on the server .
  • Disable UAC before performing these steps. 
  • Save a copy of the original files to your local drive as a backup files, in case you need to roll back later.

 

  1. Log in to your NPM server using Local Administrator account.
  2. On the Orion NPM server, click Start > All Programs > SolarWinds Orion > Advanced Features > Orion Service Manager to access your Orion Service Manager.
  3. Click Shutdown Everything to stop all services.
  4. Open CMD, and run the command iisreset /stop.
  5. Go to the following locations and delete the folder inside 'root' folder:
      -C:\Windows\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\root
      -C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\root
      -C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files\root
      -C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\root
  6. Click Start > All Programs > SolarWindsOrion > Advanced Features > Database Manager. Once there, follow the following steps:
    1. Click Add Default server.
    2. Expand your SQL server and locate your SolarWinds database.
    3. Right-click your Solarwinds database and then select New Query.
    4. On the right field, paste the following:
      delete from dbo.PendingNotifications
      delete from dbo.SubscriptionTags
      delete from dbo.Subscriptions
         
      Note: This clears out all the temporary data from the Subscriptions table.
  7. Go to C:\ProgramData\Solarwinds\installers.
  8. Right-click InformationService.msi and then click Repair.  
  9. Open CMD, and run the command iisreset /start.
  10. Go to Start > All Programs > SolarWinds Orion > Advanced Features > Orion Service Manager, and then click Start Everything.

 

Resolution 2:

Please run the Orion Configuration Wizard:

 

  1. Start > All Programs > SolarWinds Orion > Configuration and Auto-Discovery > Configuration Wizard
  2. Run Configuration Wizard for:
    1. Database
    2. Website
    3. Service
  3. Follow the onscreen prompts to complete the Configuration Wizard. 
Last modified
23:43, 22 Jun 2016

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