Submit a ticketCall us

Have You Auto Renewed? If not, you're missing out.
The SolarWinds Renewal Program comes with a host of benefits including the most recent product updates, 24/7 technical support, virtual instructor-led training and more. Experience all of this with the convenience of Auto Renewal, and never worry about missing any of these great benefits. Learn More.

Home > Success Center > Network Performance Monitor (NPM) > The Microsoft Message Queue is not growing or running

The Microsoft Message Queue is not growing or running

Updated: October 17, 2017

Overview

This article addresses an issue where some users may notice the Microsoft Message Queue (MSMQ) is growing or not running.

This issue may be caused by:

  • Resources not loading within the Web Console
  • Information Service v3 is stopped when opening the Orion Service Manager
  • Errors in the Web console stating "There was no endpoint listening at...."

Environment

  • NPM 12.0 and later
  • SAM 6.2.4 and later

Cause 

The account running MSMQ does not have sufficient permissions to access the MSMQ storage folder, which breaks the SolarWinds Information Service. The following error messages display in the Information Service v3 log:

InformationServiceV3 Log

2017-08-21 01:07:47,782 [7] ERROR SolarWinds.InformationService.ChangeBroker.Broker - (null) (null)     Couldn't grant Full Control permissions to bult-in Administrators group to queue 'private$\SolarWinds/InformationService/Orion/IndicationPublisher'. MSMQ error code: -2147024890.
System.Messaging.MessageQueueException (0x80004005)
   at System.Messaging.MessageQueue.SetPermissions(AccessControlList dacl)
   at SolarWinds.InformationService.ChangeBroker.Broker.GrantAccessToAdministrators(MessageQueue queue)
2017-08-21 01:07:47,798 [7] ERROR SolarWinds.InformationService.Core.InformationServiceService - (null) (null)     Information Service failed to open a channel.
SimpleInjector.ActivationException: The registered delegate for type IChangeBroker threw an exception.  ---> System.Messaging.MessageQueueException
   at System.Messaging.MessageQueue.SetPermissions(AccessControlList dacl)
   at SolarWinds.InformationService.ChangeBroker.Broker.GrantAccessToAdministrators(MessageQueue queue)
   at SolarWinds.InformationService.ChangeBroker.Broker.PrepareQueue(ServiceElement serviceElement)
   at SolarWinds.InformationService.Bootstrap.BrokerFactory.GetChangeBroker()
   at lambda_method(Closure )

Resolution

  1. Verify that the disk on your SolarWinds Application server is not full. 
  2. Stop all SolarWinds services.
  3. Confirm that the MSMQ Service can access the Message Queuing storage directory.
    1. Open the Services.msc console.
      Select Run and execute services.msc.
    2. Locate the Message Queuing service (MSMQ).
    3. Check the Log On As property to identify the user running the service.
    4. Confirm that the user running the service has full permissions on the Message Queuing storage directory located at %windir%\System32\msmq\storage.

You may need to purge the MSMQ depending on the volume of messages in the queue. 

 

 

Last modified

Tags

This page has no custom tags.

Classifications

Public