Submit a ticketCall us

Looking to compare latest NPM features with previous versions of NPM?
The NPM new feature summary offers a comparison of new features and improvements offered with this release.

 

Home > Success Center > Network Performance Monitor (NPM) > TLS compatibility with Orion Core Products

TLS compatibility with Orion Core Products

Table of contents

Updated: May 24th 2017

Overview

This article provides information about supported versions of TLS for products running on Orion Platform 2017.1 (such as NPM 12.1 and SAM 6.4) and earlier.

 

Orion Platform 2016.2 added support for TLS 1.1 and 1.2, but not all products that install on Orion Platform 2016.2 support TLS 1.1 or 1.2. It is also still a requirement to have TLS 1.0 to ensure complete functionality of the Orion suite with legacy tools, such as the Report Writer.

 

If you want to install additional polling engines or additional web servers, you must enable TLS 1.0 during the install process. You can use later versions of TLS after the install.

Detail

 

  • NPM 12.0.1 and later supports  TLS 1.1 and 1.2.
  • SAM 6.3 and later supports TLS 1.1 and 1.2
    • SAM is able to fallback to TLS 1.1 or  TLS 1.0 for HTTPS website polling and SSL Certificate monitoring if the later version is not working properly in your environment.
  • NTA 4.2.1 and later supports TLS 1.1 and 1.2.
  • NCM 7.5 and later has been tested with disabled TLS 1.0, and it functions without any problems. However, some legacy tools may experience issues.
  • SRM 6.3 and later supports TLS 1.1 and 1.2.
    • The following protocols will be used in descending order when negotiating the connections to arrays: TLS 1.2, TLS 1.1, TLS 1.0 and SSL 3.0. The protocol used depends on your arrays, the versions of those arrays and what they support.
    • SRM with SRM Profiler integration does not support TLS 1.1 or TLS 1.2.
  • WPM 2.2.1 supports TLS 1.1 and 1.2.
    • For monitored websites, you can enable TLS 1.1 and 1.2 for the WPM player.
  • IPAM 4.5 supports TLS 1.1 and 1.2.
  • DPAIM (DPA Integration piece) 11.0 supports  TLS 1.1 and 1.2.
  • VNQM does not support TLS 1.1 and 1.2.
  • UDT does not support TLS 1.1 and 1.2. 

 

 

 

 
Last modified
15:24, 8 Jun 2017

Tags

Classifications

Public