Submit a ticketCall us

Have You Auto Renewed? If not, you're missing out.
The SolarWinds Renewal Program comes with a host of benefits including the most recent product updates, 24/7 technical support, virtual instructor-led training and more. Experience all of this with the convenience of Auto Renewal, and never worry about missing any of these great benefits. Learn More.

Home > Success Center > Network Performance Monitor (NPM) > Syslog view error when attempting to clear selected messages: Value was either too large or too small for an Int32

Syslog view error when attempting to clear selected messages: Value was either too large or too small for an Int32

Created by Matthew Lamb, last modified by MindTouch on Jun 23, 2016

Views: 84 Votes: 0 Revisions: 5

Updated

Overview

This article addresses the following issue that occurs when attempting to clear selected Syslog Messages from the Syslog view in the Orion console:

 

The error generated displays the following:

Message: Value was either too large or too small for an Int32.
ErrorSite: mscorlib.Number.ParseInt32
ErrorType: System.OverflowException
Stack: 
at System.Number.ParseInt32(String s, NumberStyles style, NumberFormatInfo info)
at System.Convert.ToInt32(String value)
at SysLogsReportControl.ClearMessages_Click(Object sender, EventArgs e)
at System.Web.UI.WebControls.LinkButton.OnClick(EventArgs e)
at System.Web.UI.WebControls.LinkButton.RaisePostBackEvent(String eventArgument)
at System.Web.UI.WebControls.LinkButton.System.Web.UI.IPostBackEventHandler.RaisePostBackEvent(String eventArgument)
at System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument)
at System.Web.UI.Page.RaisePostBackEvent(NameValueCollection postData)
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

Environment

NPM 11.5.3 and earlier

Cause 

The occurs because the messageID column in the Syslog table is extremely large in count. When the Web Console attempts to convert that number, it fails because it is incapable of handling such a larger number. Examples of this would be if the messageID was in the high billions or trillions.

Resolution

There are 2 methods to resolve this: Upgrade to NPM v12 when it comes out or reseed the Syslog table. To reseed the syslog table, perform the following: 

  1. Stop all services.
  2. Run the following two queries through SQL Management Studio in the database:
    truncate table syslog
    dbcc checkident (syslog, reseed, 1)
  3. Restart services.

Those queries will restart the identity of that table at 1 rather than continuing at the number it is currently at. It is possible to reseed the table at 1 without truncating the table, but the range of IDs already in the database should be taken into consideration and whether the new data will reach that point before the historical data is cleared through retention.

 

 

Last modified

Tags

Classifications

Public