Submit a ticketCall us

Have You Auto Renewed? If not, you're missing out.
The SolarWinds Renewal Program comes with a host of benefits including the most recent product updates, 24/7 technical support, virtual instructor-led training and more. Experience all of this with the convenience of Auto Renewal, and never worry about missing any of these great benefits. Learn More.

Home > Success Center > Network Performance Monitor (NPM) > SolarWinds Orion 2016.2 feature: High Availability > High Availability (HA) keeps switching over between server members of primary polling engine pool

High Availability (HA) keeps switching over between server members of primary polling engine pool

Updated March 21, 2017

Overview

The primary polling engine that is set up with High Availability keeps switching over between servers.

Environment

All Orion Platform modules version 2016.2 and later

Cause

This issue is caused by a surplus record for the primary polling engine (MPEngine in HA) stored in the HA_ResourcesInstances table.

Resolution

  1. Perform one of the following options:
    • If the Orion Web Console is available:
      1. Log in to the Orion Web Console.
      2. Go to All Settings and open the High Availability Deployment Summary.
      3. Disable HA using the on/off switch under the pool.
    • If the Orion Web Console is not available:
      1. Log in to any of the servers.
      2. Open a new command line.
      3. Go to installation folder of Orion (default: C:\Program Files (x86)\SolarWinds\Orion).
      4. Execute the following command:
        HAEnableDisable /DisableHA
  2. Stop SolarWinds HighAvailability services on the servers (only Primary Polling Engine pool members) following steps below:
    1. Log in to a standby server.
    2. Open Windows Services.
    3. Stop the SolarWinds HighAvailability service.
    4. Log in to an active server.
    5. Open Windows Services.
    6. Stop SolarWinds HighAvailability service.
  3. Open Database Manager.
  4. Right-click your database, and select New query.
  5. In the query window, enter the following, and then click Execute:
    DELETE
    FROM HA_ResourcesInstances
    WHERE RefId LIKE 'Orion.HA.MPEngineResource.%'

    Note: To copy content without line numbers, hover over the text and click the view source button (View Source). This opens a new window where you can select, and copy text without any formatting or line numbering.
  6. Start SolarWinds HighAvailability services on servers (only Primary Polling Engine pool members) following steps below:
    1. Log in to active server.
    2. Open Windows Services.
    3. Start SolarWinds HighAvailability service.
    4. Log in to standby server.
    5. Open Windows Services.
    6. Start SolarWinds HighAvailability service.
  7. Perform one of the following options:
    • If Orion Web Console is available:
      1. Log in to the Orion Web Console.
      2. Go to All Settings.
      3. Open the High Availability Deployment Summary.
      4. Enable HA using the on/off switch under the pool.
    • If Orion Web Console is not available:
      1. Log in to any of the servers.
      2. Open a new command line.
      3. Go to installation folder of Orion (default: C:\Program Files (x86)\SolarWinds\Orion).
      4. Execute the following command:
        HAEnableDisable /EnableHA

 

Last modified

Tags

Classifications

Public