Submit a ticketCall us

Training Class Getting Started with SolarWinds Backup - February 28

This course offers customers an introduction to SolarWinds Backup, focusing on configuring the backup technology, taking backups, data restoration and data security. It is a great primer and will get you up to speed quickly on SolarWinds Backup.
Register for class.

Home > Success Center > Network Performance Monitor (NPM) > Scheduled Reports issue after upgrade to NPM 12

Scheduled Reports issue after upgrade to NPM 12

Updated August 22, 2016

Overview

After upgrading to NPM 12, Scheduled Reports which are sent to my emails come out similar to the screenshot below:

 

Environment

All Orion Core 2016+ products

 

Cause 

&PRINTABLE=TRUE is added in the Report URL which causes the HTML page to appear with all Forms & Menus.

Resolution

  1. Create a backup of your Orion database.
  2. Log in to the Orion Server.
  3. Stop All Orion Services using Orion Service Manager.
  4. Open Database Manager & Expand the Orion Database.
  5. Right-click the Orion Database and select New Query.
  6. Copy and Paste the following query:
    UPDATE [dbo].[ActionsProperties]
    SET [PropertyValue] = 'True'
    WHERE [PropertyName] = 'Printable' AND [ActionID] IN
    (SELECT DISTINCT ap.[ActionID] FROM [dbo].[ActionsProperties] ap
    INNER JOIN [dbo].[ActionsAssignments] aa ON aa.ActionID = ap.ActionID
    WHERE aa.[EnvironmentType] = 'Reporting' AND ap.[PropertyName] = 'ContentTypes' AND ap.[PropertyValue] LIKE '%HTML%')
  7. Restart all Orion Services.

  8. Re-Run the effected Schedule and confirm that the Report is now executing correctly.

 

 

 

 

Last modified

Tags

Classifications

Public