Submit a ticketCall us

Announcing NCM 7.7
With NCM 7.7, you can examine the rules that make up an access control list for a Cisco ASA device. Then you can apply filters to display only rules that meet the specified criteria, order the rules by line number or by the hit count, and much more.
See new features and improvements.

Home > Success Center > Network Performance Monitor (NPM) > Run-time error 339 when opening Syslog Viewer or Trap Viewer

Run-time error 339 when opening Syslog Viewer or Trap Viewer

Table of contents
No headers
Created by Interspire Import, last modified by Carlos Vigier on Jun 16, 2017

Views: 228 Votes: 1 Revisions: 15

Issue:

The following error occurs when opening 'Syslog Viewer' and 'Trap Viewer'.

"Run-time error '339'. Component 'InnovaDSXP2.ocx' or one of its dependencies not correctly registered: a file is missing or invalid" 

Cause:

The file named 'InnovaDSXP2.ocx' was missing or invalid.

Resolution:

  1. Run a repair on the Core Services - Repairing Orion Core Services.
  2. Click Start > Run > cmd > Type regsvr32 'C:\Program Files (x86)\Common Files\SolarWinds\InnovaDSXP2.ocx' 
  3. This error can also happen if the antivirus is blocking the file. Please verify antivirus exclusions are implemented. 

 

https://support.solarwinds.com/Succe...ory_exclusions

 

*For 64-Bit version of the OS you may need to go to folder C:\Windows\SysWOW64 in the command line and run the regsrv32 program from there and opposed to the default regsrv32 program found in C:\Windows\system32. Check the path in the command line to find what program the command prompt defaults to.

** You may also need to unregistered the file and re-register it. Use the u parameter to unregistered the file (i.g. regsvr32 /u 'C:\Program Files (x86)\Common Files\SolarWinds\InnovaDSXP2.ocx'

Last modified
08:43, 16 Jun 2017

Tags

Classifications

Public