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Home > Success Center > Network Performance Monitor (NPM) > Plugin "Core Business Layer" failed to start exception The file exists

Plugin "Core Business Layer" failed to start exception The file exists

Created by Adrian Cook, last modified by Malik Haider on Jul 02, 2016

Views: 243 Votes: 8 Revisions: 8

Overview

This article provides brief information and steps to resolve the error when the Core Businesslayer plugin crashes on Start up: 

2016-02-15 13:12:16,761 [8] ERROR SolarWinds.BusinessLayerHost.PluginInstanceAppDomain - Plugin "Core Business Layer" failed to start.
System.IO.IOException: The file exists.

   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
   at System.IO.__Error.WinIOError()
   at System.IO.Path.InternalGetTempFileName(Boolean checkHost)
   at SolarWinds.Orion.Core.CertificateUpdate.Md5CertificateUpdater..ctor(Boolean onlySynchronizeCertificateWithDatabase, TimeSpan agentStatusPollFrequency)
   at SolarWinds.Orion.Core.BusinessLayer.CoreBusinessLayerService..ctor(CoreBusinessLayerPlugin pluginParent, IFeatureManager featureManager, IPackageManager packageManager, INodeBLDAL nodeBlDal, IAgentInfoDAL agentInfoDal, ISettingsDAL settingsDal)
   at SolarWinds.Orion.Core.BusinessLayer.CoreBusinessLayerService..ctor(CoreBusinessLayerPlugin pluginParent, IFeatureManager featureManager)
   at SolarWinds.Orion.Core.BusinessLayer.CoreBusinessLayerPlugin.Start()
   at SolarWinds.BusinessLayerHost.Contract.BusinessLayerPlugin.Start()
   at SolarWinds.BusinessLayerHost.PluginInstanceAppDomain.Start()
2016-02-15 13:12:16,761 [8] INFO  SolarWinds.BusinessLayerHost.PluginInstanceSeparateProcess - Starting plugin E:\Program Files (x86)\SolarWinds\Orion\AgentManagement\SolarWinds.AgentManagement.ServiceCore.dll.config - ProcessID:33112

 

The error above is referencing InternalGetTempFileName during the certificate update.

Environment

  • NPM version 11.5.3
  • SAM version 6.2.3

 

Cause 

The issue is caused by the amount of files in C:\Windows\Temp having too many files.

Resolution

  1. Stop the Orion services using Orion Service Manager.
  2. Remove all files under C:\Windows\Temp
  3. Restart the Orion services and it should no longer crash the Core Plugin on Start up.


 

 

 

Last modified
07:39, 2 Jul 2016

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