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Home > Success Center > Network Performance Monitor (NPM) > PDF and CSV report attachment not working after changing the website of NPM to HTTPS

PDF and CSV report attachment not working after changing the website of NPM to HTTPS

Created by John Salvani, last modified by MindTouch on Jun 23, 2016

Views: 1,036 Votes: 2 Revisions: 6

Overview

 

The following error occurs on email reports after changing the Orion NPM website ffrom HTTP to HTTPS:

 

   Unable to retrieve url: https://<Server Name>:443/Orion/Report.aspx?ReportID=***using PDF type.

  Unable to retrieve url: https://<Server Name>:443/Orion/Report.aspx?ReportID=*** using CSV type.

  Unable to retrieve url: https://<Server Name>:443/Orion/Report.aspx?ReportID=*** using HTML type.

 

However, generating the report manually works fine from the Orion Web Console.

Environment

NPM version 10.6 or later

 

Cause 

The issue is caused when HTTPS is not correctly configured on the Orion NPM server.

Resolution

 

Important: All Unassigned IP Address must be used when you click the Edit Bindings on the Orion Website via IIS Manager. 

 

1. Launch the Orion Database Manager from the Orion server. Click Start > All Programs > SolarWinds Orion > Advanced Features.

2. From the Orion Database Manager, click Add Default Server. This will connect to the SQL server hosting the SolarWinds database.

3. Expand the SQL server and look for the SolarWinds database.

4. Expand the SQL database and look for Websites table.

5. Right-click Websites table and select Query Table.

6. Click Execute query. To change the value of the table, click Enable Table Editing.

7. The Servername must be set to FQDN of the Orion Server, for example, servername.domain.com.

8. SSLEnabled must be set to 1, and the Port is set to 443.

9. IPAddress field should be All Unassigned.

10. Click Enable Table Editing button again to save the changes.

11. Restart all Orion services via Orion Service Manager. 

 

 

 

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