Submit a ticketCall us

Have You Auto Renewed? If not, you're missing out.
The SolarWinds Renewal Program comes with a host of benefits including the most recent product updates, 24/7 technical support, virtual instructor-led training and more. Experience all of this with the convenience of Auto Renewal, and never worry about missing any of these great benefits. Learn More.

Home > Success Center > Network Performance Monitor (NPM) > Orion services stop unexpectedly and rebooting the server allows the software to work for a limited time

Orion services stop unexpectedly and rebooting the server allows the software to work for a limited time

Created by Con Finucane, last modified by Matthew.Orr on Jul 31, 2017

Views: 802 Votes: 7 Revisions: 9

Overview

This article describes the issue when Orion services stop unexpectedly and rebooting the server allows the software to work for a limited time. You also get the following error in the Orion Information Logs:

ERROR <SolarWinds.InformationService.Contract2.InfoServiceProxy - An error occured opening a connection to the orion communication service.
System.InsufficientMemoryException: Insufficient winsock resources available to complete socket connection initiation. ---> System.Net.Sockets.SocketException: An operation on a socket could not be performed because the system lacked sufficient buffer space or because a queue was full 127.0.0.1:17777>


ERROR < SolarWinds.InformationService.ChangeBroker.NotificationManager - (null)  Error Error delivering pending notification.  SubscriptionId 755d6a39-cda9-44e2-9b96-68564df7bbfe Address net.tcp://localhost:17777/SolarWinds/PubSub/NcmSubscriber
System.InsufficientMemoryException: Insufficient winsock resources available to complete socket connection initiation. ---> System.Net.Sockets.SocketException: An operation on a socket could not be performed because the system lacked sufficient buffer space or because a queue was full 127.0.0.1:17777>

Event Log Errors < Event id : 4227 TCP/IP failed to establish connection >

Environment

All versions of NPM

 

Cause 

An AntiVirus software blocking the creation of new sockets.

Resolution

  1. Check the total number of of open sockets.
  2. Run the following command from an elevated command line  in Windows:
    1.  netstat -nao | find /i "ESTAB" /c

This will give you the number of connections. The default maximum for windows is 16,384. If the total open is below the default then the Anti Virus software can be blocking.

 

  1. Remove the Anti Virus software or reconfigure to prevent it form blocking the creation of sockets.
  2. Restart the server.

 

 

Last modified

Tags

Classifications

Public