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Home > Success Center > Network Performance Monitor (NPM) > Orion Web Console charts error: Data is not available

Orion Web Console charts error: Data is not available

Created by Interspire Import, last modified by Su-Lyn Rosenberry on Aug 30, 2017

Views: 654 Votes: 0 Revisions: 23

Overview

The following error appears in the Orion Web Console when viewing new charts introduced in version 2012.1:

Data is not available

Environment

Orion Platform 2012.1 and later.

Cause

This error is caused by one of the following issues:

  • Not all data are cached or collected for the selected time frame for display in the chart.
  • The viewed network object was recently added and did not complete a full polling cycle. 
  • During the charted time period, the viewed network object is or was in an unmanaged state. 
  • If you are monitoring hardware health, some devices may have sensors reporting status only. These sensors do not provide values that can be displayed by a chart.
  • The node volume or Interface is not being monitored and is unchecked in List Resources.
  • If you are monitoring netflow with SolarWinds NTA and cannot see any data, make sure you have configured devices properly to export flow data. 

Resolution

Perform the following steps:

  1. Click Edit on the resource and change the timeframe. Not all data are cached or collected for the selected timeframe to display in the chart.
  2. Wait 10 minutes and then refresh your screen. If you added the network object within the last few minutes, the Orion platform may require additional time to complete a full polling cycle. As a result, the data will be written to the database and displayed in the web console within a certain period of time—usually within 10 minutes. 
  3. Verify that the network object is not in an unmanaged state. Open Web Node Management and confirm the managed state of the viewed node. See Setting Device Management States for details. 
  4. Verify that the device sensors provide both status and values. If you are monitoring hardware health, some devices may report status only and do not report values that display in a chart. See Monitoring Hardware Health for details. 
  5. Ensure that the interfaces or volumes are being monitored correctly. To verify, navigate to Node Details and click List Resources.  
  6. Verify the time variables used in the chart. Use ${toTime} or ${toTimeUTC}  instead ${untilTime}. Alternatively, filter by time in the chart and not in the query.
  7. Contact SolarWinds Customer Support for further assistance. If these steps do not successfully resolve the issue, you may have an issue preventing database communication or effective polling of the viewed network object, Contact SolarWinds Customer Support for assistance in diagnosing a polling or database error.
Last modified
13:41, 30 Aug 2017

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