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Home > Success Center > Network Performance Monitor (NPM) > Objects missing in Network Atlas

Objects missing in Network Atlas

Created by Mariusz Handke, last modified by MindTouch on Jun 23, 2016

Views: 224 Votes: 2 Revisions: 6

Overview

This article provides explanation and solution to the issue observed when opening Network Atlas and seeing empty list of objects, similar to screenshot below:

 

 

In the log (c:\ProgramData\Solarwinds\NetworkAtlas\NetworkAtlas.log) following error is captured:

2015-12-18 13:43:13,026 [6] ERROR MapEngine - Error in Engine:ParseTable.
System.ServiceModel.FaultException`1[SolarWinds.InformationService.Contract2.InfoServiceFaultContract]: RunQuery failed, check fault information. (Fault Detail is equal to SolarWinds.InformationService.Contract2.InfoServiceFaultContract).
Exception type: System.ServiceModel.FaultException`1[SolarWinds.InformationService.Contract2.InfoServiceFaultContract]
Detail: SolarWinds.InformationService.Contract2.InfoServiceFaultContract
Message: Invalid column name 'PONumber123'.
Action: http://www.w3.org/2005/08/addressing/soap/fault
Code: System.ServiceModel.FaultCode
IsPredefinedFault: True
IsSenderFault: True
IsReceiverFault: False
Namespace: http://www.w3.org/2003/05/soap-envelope
Name: Sender
Message: RunQuery failed, check fault information.
Reason: RunQuery failed, check fault information.
Data: System.Collections.ListDictionaryInternal
TargetSite: Void CreateFaultException(System.ServiceModel.Channels.Message)
StackTrace:    at SolarWinds.InformationService.Contract2.InformationServiceQuery.CreateFaultException(Message response)
   at SolarWinds.InformationService.Contract2.InformationServiceQuery.Execute(Boolean hierarchical)
   at SolarWinds.InformationService.Contract2.InformationServiceQuery`1.<GetEnumerator>d__0.MoveNext()
   at SolarWinds.MapEngine.Engine.ParseTable(IEnumerable`1 mngEntities, Entity entity, NetObject parentNetObject)
Source: SolarWinds.InformationService.Contract2

Environment

All versions of Network Atlas

Cause 

  1. This issue is caused by Custom Property metadata existing while property is not created for specific objects (i.e. nodes).
  2. This can also be caused if you have NW Atlas installed on your workstation and it is not the correct version as the server.

Resolution

This issue is caused by Custom Property metadata existing while property is not created for specific objects (i.e. nodes).

  1. Log in to the Orion Web Console.
  2. Go to Settings > Manage Custom Properties.
  3. Find the property, select it and click Delete.
  4. Re-open Network Atlas.

 

This can also be caused if you have NW Atlas installed on your workstation and it is not the correct version as the server.

  1. Log onto server and make sure that you are able to see Orion objects on the left
  2. Check the version number of NW Atlas and compare that to the workstation version
  3. If not correct copy the installer file of NW Atlas from C:\programdata\Solarwinds\Installer and run the program on the workstation.
  4. After the check to see if the Orion Objects are there

 

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