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Home > Success Center > Network Performance Monitor (NPM) > Node/application credential from poller is locked out

Node/application credential from poller is locked out

Created by Riggs Clough, last modified by Harry Griffiths on Mar 02, 2018

Views: 1,297 Votes: 2 Revisions: 8

Overview

This article addresses the issue where a node or application credential from a SolarWinds poller is locked out.

Environment

  • All SAM versions
  • All NPM versions

Cause 

This can occur when credentials are cached on a SW Service.

Resolution

1. Please follow the Steps to see what WMI Credential is Assigned to What Node?

Please click Here: What Credentials Are Assigned To Each Node?
 

2. Confirm that the Windows Credentials have been updated in: 

Settings > Credentials > Manage Window credentials

 

 

Note: Verify that you have run the query in https://support.solarwinds.com/?titl...monitoring_SAM such that the credentials in question do not exist.

If none of the above helps, there may be a problem with the SDF files which house jobs on your server(s). Please follow these instructions on all of your Orion pollers to replace the SDF files:

Note: Reinstalling these services is the quickest way to replace the SDF files - you do not need to replace them manually, in most cases. However, in some cases it is necessary to manually replace the SDF files. 

  1. Navigate to the Orion Poller that is causing the lockout.
  2. Shut down all Orion Services using Orion Service Manager.
  3. Go to C:\ProgramData\SolarWinds\Installers
  4. Right-click and uninstall the following
    • JobEngine.msi
    • Jobengine.v2.msi
    • CollectorInstaller.msi 
  5. Rerun the following to reinstall the services:
    • JobEngine.msi
    • Jobengine.v2.msi
    • CollectorInstaller.msi 
  6. If the installer asks for installation type, choose Typical install.
  7. Once all installers are re-installed, start all Orion Services back up with Orion Service manager.

Note: If you get an error that SolarWinds Job Engine v1.6.0 Setup Wizard ended prematurely because of an error, perform the following:

Go to C:\ProgramData\Solarwinds\Installers

  1. Right-click JobEngine.msi
  2. Select Properties.
  3. Go to the Compatibility tab.
  4. Select Compatibility Mode == Run this program in compatibility mode for: ==
  5. Select Previous version of Windows or Windows XP.
  6. Click Apply.
  7. Execute JobEngine.msi
    If the Job engine service does not want to reinstall check to see if you have User account control enabled. If so, turn it off and reboot the server and then the service should install.
  8. If unresolved, please follow this article. 
    https://support.solarwinds.com/Success_Center/Network_Performance_Monitor_(NPM)/Orion_is_locking_me_out_of_active_directory

 

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