Submit a ticketCall us

Don’t fall victim to a ransomware attack
Backups are helpful, but sometimes that’s not enough to protect your business against ransomware. At our live webcast we will discuss how to protect against ransomware attacks with SolarWinds® Patch Manager and how to leverage log data to detect ransomware. Register now for our live webcast.

Home > Success Center > Network Performance Monitor (NPM) > New Feature Summary NPM > Unable to scan existing Images. see NcmBusinessLayerPlugin.log for details

Unable to scan existing Images. see NcmBusinessLayerPlugin.log for details

Updated

Overview

 

NcmBusinessLayerplugin log


ERROR SolarWinds.Cirrus.BusinessLayer.FirmwareUpgrade.FirmwareRepositoryWatcher - FileSystemWatcher Created errorSystem.ServiceModel.FaultException`1[SolarWinds.InformationService.Contract2.InfoServiceFaultContract]: Create failed, check fault information.
The target table 'dbo.NCM_FirmwareUpgradeImages' of the DML statement cannot have any enabled triggers if the statement contains an OUTPUT clause without INTO clause. (Fault Detail is equal to InfoServiceFaultContract [ System.Data.SqlClient.SqlException (0x80131904): The target table 'dbo.NCM_FirmwareUpgradeImages' of the DML statement cannot have any enabled triggers if the statement contains an OUTPUT clause without INTO clause.

 

Error scanning firmware repository

Environment

  • NCM 7.6

 

Cause 

 

 Trigger to NCM_FirmwareUpgradeImages table was added which is not allowed

Resolution

1.Run MS SQL Management Studio 
2.Go to NCM_FirmwareUpgradeImages table -> Triggers. 
3.Select the trigger(s) and disabled it, if that will not help then delete it. Restart all services in Orion service manager.

 

 

 

 

Last modified
16:12, 18 May 2017

Tags

This page has no custom tags.

Classifications

Internal Use Only