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Home > Success Center > Network Performance Monitor (NPM) > UnDP tool stopped working

UnDP tool stopped working

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Created by Interspire Import, last modified by MindTouch on Jun 23, 2016

Views: 1,396 Votes: 0 Revisions: 10

Issue:

The Universal Device Poller (UnDP) tool stopped working with the following error message in the UnDP tool logs:

ERROR CustomePollerManagerController - GettingIcons - Unspecified error System.ServiceModel.FaultException'1[System.ServiceMOdel.ExceptionDetail]: Unspecified error (Fault Detail is equal to An ExceptionDetail, likely created by IncludeExceptionDetailInFaults=true, whose value is: System.Data.OleDb.OleDbException: Unspecified error

Cause:

UnDP stopped working because Management Information Base (MIBs.cfg) wasn't installed. 
 

Resolution:

There are two options on restoring the MIBs.cfg database. Please see the following steps:

Option 1:
  1. Check and verify if the MIBs.cfg is not locked by other process.
  2. Open Add/Remove programs > Search and right-click SolarWinds MIBs. 
The MIBs should be restored from the installer. 
Option 2:
  1. Get the latest MIBs.cfg from the following link: http://downloads.solarwinds.com/solarwinds/Release/MIB-Database/MIBs.zip
  2. Replace the file manually. 
Note: After repair, check permissions on MIBs.cfg if accessible. 

User can now start Universal Device Poller (UnDP) application as Administrator.
 
If the above steps did not help, make sure there is a “Common” folder where NPM is installed:
 
Copy the “Common” folder from the path: C:\Program Files (x86)\SolarWinds\Common to your X: drive - X:\Program Files (x86)\SolarWinds\

Applies to: NPM 11.5 
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