Submit a ticketCall us

Looking to compare latest NPM features with previous versions of NPM?
The NPM new feature summary offers a comparison of new features and improvements offered with this release.

 

Home > Success Center > Network Performance Monitor (NPM) > Module engine crashing with System.Data.SqlServerCe.SqlCeErrorCollection error

Module engine crashing with System.Data.SqlServerCe.SqlCeErrorCollection error

Created by Adrian Cook, last modified by MindTouch on Jun 23, 2016

Views: 31 Votes: 3 Revisions: 4

Overview

This article describes the issue when you see the Module engine or Businesslayer crashing every few minutes. You can check this by going to C:\ProgramData\Solarwinds\Logs\Orion and look at the previous Businesslayerhost.log for the error below:

2015-12-16 10:24:21,691 [104] ERROR SolarWinds.BusinessLayerHost.BusinessLayerHostService - Unhandled exception caught by business layer host. System.Runtime.Serialization.SerializationException: Type 'System.Data.SqlServerCe.SqlCeErrorCollection' in Assembly 'System.Data.SqlServerCe, Version=3.5.1.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91' is not marked as serializable.

The key word here is SqlServerCe.

 

Environment

All versions of NPM and modules

Cause 

The error is caused by corruption in the SQL Server Compact Edition databases used by the services.

Resolution

  1. Stop the Orion Services.
  2. Go to C:\ProgramData\Solarwinds\Installers.
  3. Run the installers for the JobEngine, JobEngine.v2, and CollectorInstaller and uninstall the services.
  4. Run the installers for SSCERuntime_x64-ENU and SSCERuntime_x86-ENU and choose repair on each.
  5. Once the repairs are done, run the installers to JobEngine, JobEngine.v2, and CollectorInstaller and reinstall the services.
  6. Restart the Orion Services and give it at least five minutes to come up completely. The Module engine should no longer be crashing.

 

If the steps above are ineffective, proceed as follows:

  1. Stop the Orion Services.
  2. Go to C:\ProgramData\Solarwinds\Installers.
  3. Run the installers for the JobEngine, JobEngine.v2, and CollectorInstaller and uninstall the services.
  4. Uninstall Microsoft SQL Server Compact 3.5 SP2 ENU, and x64 ENU from Programs and Features
  5. Download and install Microsoft SQL Server Compact 3.5 Service Pack 2 for Windows Desktop from: https://www.microsoft.com/en-us/down...s.aspx?id=5783
  6. Go to C:\ProgramData\Solarwinds\Installers.
  7. Run the installers for the JobEngine, JobEngine.v2, and CollectorInstaller and install the services.  
  8. Restart the Orion Services and give it at least five minutes to come up completely. The Module engine should no longer be crashing.

 

Note:  In some environments it may be necessary to run the installers for the JobEngine, JobEngine.v2, and CollectorInstaller from a command prompt that was run as administrator.  To change the directory use the following command:

 

cd C:\ProgramData\Solarwinds\Installers

 

 

 

Last modified
22:42, 22 Jun 2016

Tags

Classifications

Public