Submit a ticketCall us

Webinar: Web Help Desk for HR, Facilities and Accounting Departments
This webinar will focus on use cases for HR, Facilities and Accounting.

Having a unified ticketing and asset management system for all the departments in your company can provide end-users with a seamless experience and make things easier for your IT team. Yet, with different business tasks and objectives, many departments don’t fully understand the capabilities of Web Help Desk and how the software can be customized for effective use in their departments.
Register Now.

Home > Success Center > Network Performance Monitor (NPM) > List of alert variables for nodes is missing

List of alert variables for nodes is missing

Updated June 19, 2017

Overview

A variety of alerts trigger emails based on its criteria. For many of these emails, the NODE VARIABLES option is used in the Alert Manager to fill out pertinent details on the email that is sent. This was working fine until some alerts no longer include any of the variable data, and instead displays the raw variable code. When the alerts are inspected, all the preset variables are missing under the Variable under the Nodes drop-down. As a result, the emails that are generated have nothing in reference and just includes raw variables.

 

The actual alert includes correct details and only the email that gets sent information is missing.

 

Environment

NPM 11.5

Cause 

The Alerthistory table is too large and needs to be truncated.

Resolution

  1. Open Database Manager.
  2. Run the following query:
    truncate table alerthistory
  3. Stop and restart all services using the Orion Services Manager.

 

SolarWinds strongly recommends upgrading to NPM 12.0.1 to resolve the issue.

 

Last modified
16:55, 19 Jun 2017

Tags

Classifications

Public