Submit a ticketCall us

Get a crash course on Network Monitoring delivered right to your inbox
This free 7-day email course provides a primer to the philosophy, theory, and fundamental concepts involved in IT monitoring. Lessons will explain not only how to perform various monitoring tasks, but why and when you should use them. Sign up now.

Home > Success Center > Network Performance Monitor (NPM) > License migration utility experienced an error during Configuration Wizard

License migration utility experienced an error during Configuration Wizard

Updated: 4-5-2017

Overview

An issue occurred with the license migration utility, Migration.exe. 

The utility did not migrate existing licenses from your additional polling engine or additional web server to your main poller for the web-based License Manager. The web-based License Manager stores all licenses in a product license store on the main polling engine for all servers in your Orion environment.

 

You may receive the error: "The license migration utility experienced an error. Product licenses were not transferred correctly." To determine the specific reason for the failure, see c:\.....\SolarWinds.Orion.Licensing.Migration.log.

To resolve, complete the troubleshooting steps listed below in the Resolution section and run the Configuration Wizard again on the additional poller.

You may want to enter a ticket with Support to troubleshoot. The steps may be advanced requiring command line commands.

 

Environment

  • Products running on Orion Platform 2016.2 and later, such as NPM 12.0.1 and later and SAM 6.3 and later
  • Web-based License Manager

 

Cause 

An error occurred during the migration of license information to the Main Poller/Engine. The server was unable to resolve the main poller hostname to make a proper connection to the licensing server or the firewall was blocking the traffic between the two servers.

 

Resolution

Troubleshoot the issue following one of these solutions. To determine the specific reason for the failure, see c:\.....\SolarWinds.Orion.Licensing.Migration.log.

 

After resolving the issue with the troubleshooting command, please run the Configuration Wizard.  The Configuration Wizard will verify the licenses on the poller and resolves the web configuration.

 

Issue: If there is a "communication exception", do the following:

  1. Check the system listed in the exception error message located in the migration utility log (c:\.....\SolarWinds.Orion.Licensing.Migration.log).
  2. You can modify your hosts file if there is a DNS problem. Add an IP entry for the unreachable server listed in the error message.
    The hosts file is located in %systemroot%\system32\drivers\etc. For 64-bit, look in the 64-bit system32 directory. Use a program like notepad (Run as administrator) to edit the file.
  3. In rare cases, ensure port 17777 is not blocked by firewalls.
  4. Verify the Orion Module Engine is up and running on the system the web-based license manager is attempting to connect to (the system listed in the exception error message located in the migration utility log).
  5. You can also check the licensing business layer host log at \ProgramData\SoalrWinds\Logs\Orion\Licensing\SolarWinds.Orion.Licensing.BusinessLayer.log for errors.
  6. If you cannot locate a communication error, open a support ticket.

 

Issue: The licenses were not moved to main poller and are not visible to web UI and scalability engines.

Troubleshoot with this command: Migration.exe /console=debug /move

This command moves the licenses correctly.

 

Issue: The scalability engine evaluation was not started. This issue may occur when no commercial or other evaluation licenses are present). Troubleshoot with this command: Migration.exe /console=debug /eval=start

This command resolves the scalability evaluation.


Issue: Leases not transported to this machine. The Configuration Wizard encounters an error not locating licenses. Troubleshoot with this command: Migration.exe /console=debug /leases=pull

 

 

 

Last modified
11:23, 17 Apr 2017

Tags

Classifications

Public