Submit a ticketCall us

Have You Auto Renewed? If not, you're missing out.
The SolarWinds Renewal Program comes with a host of benefits including the most recent product updates, 24/7 technical support, virtual instructor-led training and more. Experience all of this with the convenience of Auto Renewal, and never worry about missing any of these great benefits. Learn More.

Home > Success Center > Network Performance Monitor (NPM) > License Manager page shows Installed Version 0.0 under Orion Additional Polling Engine

License Manager page shows Installed Version 0.0 under Orion Additional Polling Engine

Created by Allain M Umalin, last modified by Karen Valdellon on Jun 13, 2017

Views: 46 Votes: 1 Revisions: 7

Updated June 13, 2017

Overview

When accessing the License Manager page, Installed Version 0.0 is shown under the Orion Additional Polling Engine license.

Environment

  • NPM 12.0
  • NPM 12.0.1
  • NPM 12.1
  • Orion Platform 2017

Cause 

This issue occurs when there are duplicate DLL configuration files saved in the Orion installation folder. The following errors indicate that the SolarWinds.Orion.Core.BusinessLayer-Orig.dll.config file requires the DLL file. The files are duplicates based on the DLL and CONFIG file names. You can verify the presence of such files in OrionDirectoryContent.txt from the main polling engine diagnostics.

  • Licensing.BusinessLayer.log:
    2017-06-07 08:37:31,576 [6] ERROR SolarWinds.Licensing.Gen4.Utils.SignUtil - error obtaining timestamp from signature
    ): The system cannot find the file specified0x80004005System.ComponentModel.Win32Exception (
       at SolarWinds.Licensing.Gen4.Utils.SignUtil.GetTimeStamp(String filename)
    \Orion\Modules\Orion.xml'SolarWinds)\x86 file 'C:\Program Files (config2017-06-07 08:37:31,591 [6] ERROR SolarWinds.Orion.Licensing.Initialization.ModuleInventory - unexpected error processing module
    \Orion\SolarWinds.Orion.Core.BusinessLayer-Orig.dllSolarWinds)\x86System.IO.FileNotFoundException: C:\Program Files (
    )fileName   at System.Diagnostics.FileVersionInfo.GetVersionInfo(String
       at SolarWinds.Orion.Licensing.Initialization.ModuleInventory.FillAuxDetails(Entry entry)

       at SolarWinds.Orion.Licensing.Initialization.ModuleInventory.GetEntries(String installPath, String filePath)

  • SolarWinds.Orion.Licensing.Migration.log:

    2017-05-29 10:12:26,508 [12] INFO  ProcessRunner - stdout: Machine Role: MainWithStore
    Migration Tasks: InitializeLeases
    Initializing leases.
    [SignUtil] ERROR: error obtaining timestamp from signature
    System.ComponentModel.Win32Exception (0x80004005): The system cannot find the file specified
       at SolarWinds.Licensing.Gen4.Utils.SignUtil.GetTimeStamp(String filename)
    [ModuleInventory] ERROR: unexpected error processing module config file 'C:\Program Files (x86)\SolarWinds\Orion\Modules\Orion.xml'
    System.IO.FileNotFoundException: C:\Program Files (x86)\SolarWinds\Orion\SolarWinds.Orion.Core.BusinessLayer-Orig.dll
       at System.Diagnostics.FileVersionInfo.GetVersionInfo(String fileName)
       at SolarWinds.Orion.Licensing.Initialization.ModuleInventory.FillAuxDetails(Entry entry)
       at SolarWinds.Orion.Licensing.Initialization.ModuleInventory.GetEntries(String installPath, String filePath)

    Local leases were initialized with the assumption that there are no HA pools.

Resolution

  1. Remove the associated CONFIG file or change its extension to skip processing such files from the main polling engine. In this case, delete SolarWinds.Orion.Core.BusinessLayer-Orig.dll.config.

  2. Restart Orion services on the main polling engine.

 

Suggested Tags:  

Installed Version 0.0

A reason for rework or Feedback from Technical Content Review:

 

 

Last modified

Tags

Classifications

Public