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Home > Success Center > Network Performance Monitor (NPM) > L2 and L3 Topology information is not showing

L2 and L3 Topology information is not showing

Created by John Salvani, last modified by Brian Collins on Jan 03, 2017

Views: 256 Votes: 0 Revisions: 8

Overview

There is no information available in the L2/L3 topology of a node.

Environment

NPM 10.6 and later

Cause 

A custom property name is created with an existing name on the NPM tables. For example, MAC, IP Address, or Routers.

Resolution

Warning:

  • Consult your System Administrator before performing the following procedure.
  • SolarWinds strongly recommends that you only edit the TopologyCalculator.log file as instructed. Any additional modifications may result in system performance issues or may create an error state.
  • Save a copy of the original TopologyCalculator.log file to your local drive as a backup file, in case you need to roll back later.

 

  1. Go to \ProgramData\Solarwinds\Logs\Orion and open the file TopologyCalculator.log in any text editor.
  2. Locate the following error:

    2015-12-07 12:58:25,392 [1] ERROR TopologyCalculator.Program - Failed, exception: System.Data.SqlClient.SqlException (0x80131904): Ambiguous column name 'MAC'.
     
  3. Delete the custom property that has named 'MAC'. This is in conflict with the existing name present on NPM server.
Last modified
15:17, 3 Jan 2017

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