Submit a ticketCall us

AnnouncementsTHWACKcamp 2018 is here

2018 is the seventh year for THWACKcamp™, and once again we’ll be live October 17 – 18 with packed session tracks covering everything from network monitoring and management, to change control, application management, storage, cloud and DevOps, security, automation, virtualization, mapping, logging, and more.

Register for online sessions.

Home > Success Center > Network Performance Monitor (NPM) > NPM - Knowledgebase Articles > Version mismatch error when installing a new additional poller

Version mismatch error when installing a new additional poller

Created by Matthew Lamb, last modified by Rodim Suarez_ret on Aug 16, 2016

Views: 1,181 Votes: 0 Revisions: 6

Updated August 16, 2016

Overview

This article goes over an issue that can occur when the primary poller is using NPM 11.5.2 or earlier with NCM 7.4.2 installed. When attempting to install NPM 11.5.2 on a new additional poller, you receive this error:

The version of Orion Core installed on your primary Orion server is newer than the versions of Orion Core that you are trying to install on your additional server.

You must install the Additional Poller or Additional Web Server of a module that provides the newer Orion Core on your additional server first.

For the recommended module installation order, see the documentation provided in the Additional Poller and Web Server Package.

 

 

Environment

  • Multiple pollers
  • NPM 11.5.2 and earlier
  • NCM 7.4.2

Cause 

When NCM 7.4.2 was installed on the primary poller, it installed the latest version of Core as well. Since the NPM 11.5.2 installer contains an older version of Core than what is installed on the primary poller, then the mismatch happens.

Resolution

  1. Install NCM 7.4.2 on the additional poller first.
  2. Install NPM 11.5.2 after NCM 7.4.3 is finished.

 

Last modified

Tags

Classifications

Public