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Home > Success Center > Network Performance Monitor (NPM) > NPM - Knowledgebase Articles > Unable to receive server reboot alert emails

Unable to receive server reboot alert emails

Updated July 18, 2017

Overview

This article describes an issue where NPM does not send alert email notifications after a server reboot.

Note: There is a known issue in NPM 12.0 and 12.1 where reboot alert notifications are not being sent. A fix is scheduled in NPM 12.1 hotfix 1.

Environment

All NPM versions

Cause 

The alert is incorrectly configured or NPM is unable to detect a reboot when it occurs.

Resolution

Note: Check the alert and make sure that the Trigger Conditions, Time of Day, and Trigger Actions are correctly configured.

  • The Trigger Condition should be set to the following:
    Trigger alert when > All child conditions must be satisfied (AND) > Last boot has changed (Node Event) - Event must occur at least 1x
  • The Time of Day should always be enabled. 

 

  1. On the Trigger action tab, verify and simulate the email or alert action. 
  2. On the Simulate screen, select a test node, and then click Execute.
    If the test fails and no email notification is received, verify that the correct email address is listed and the email server is not blocking the email address.
  3. Verify the node using an SNMP test:
    1. Go to Settings > Manage Nodes.
    2. Locate and select the node.
    3. Click Edit Node.
    4. Click the Test button for SNMP.
      If the test fails, verify that the service is up on the server. Make sure that the IP address and community string are accepting packets from the SolarWinds server.
  4. Check the Last Boot Time on the Node Details page. If the time did not change, verify that SNMP is polling.


Note: There are several reported bugs regarding reboot alerting. Please contact SolarWinds Support for further troubleshooting and investigation.

 

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